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Basics

2 Basics

2.1Introduction to jinnee

Jinnee is the user interface of choice for use with the MagiC operating system
published by Application Systems Heidelberg (ASH). jinnee offers many
functions which we believe you’ll find make working with your computer
more enjoyable. jinnee combines the best features of other Atari desktops
with features from the Macintosh Finder and Windows 95 desktops to offer
Atari enthusiasts the best desktop ever!

These instructions are designed to form a detailed description of all the
menu items and dialog boxes. We recommend you read through them
completely at least once and suggest re-reading them after using jinnee for
several weeks you'll be amazed at what you pick up the second time around.

After this, constant references to the printed manual should no longer be
necessary, as jinnee offers context sensitive help in both BubbleGEM and
ST-Guide hypertext formats.
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Every dialog box can optionally display a help line, taken from the
BubbleGEM help, across its bottom edge, although the text may be truncated
if there’s not enough room in the dialog. The help text changes as the mouse
is moved over objects in the dialog box and provides an easy way to see
which items have bubble help texts available. For short entries it also offers
an alternative to BubbleGEM help.

If ST-Guide is installed on the system, pressing the Help key or selecting
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Special > Context help... (this is a shorthand way of writing “The ‘Context help...
entry in the ‘Special drop-down menu”) displays context sensitive help from
the jinnee hypertext where available.

2.1.1 Configuring jinnee

In jinnee almost everything is configurable which makes it hard to describe
all the possibilities. This documentation describes the default settings first,
followed by the other available options, which should help avoid confusion.
Using the BubbleGEM help in conjunction with the hypertext is a useful
way to solve problems.

Note that, as usual, a “click” or “double-click” without further qualification
means one or two short presses of the left mouse button; a right-click is
always described as such.

Many of jinnee’s dialogs contain editable fields for specifying various files
that are used by some of its functions. Although you can type in the filename
manually (complete with path), it is usually easier to double-click on the
field to bring up a file selector which you can use to locate the desired file
and path quickly and easily.

2.1.2 Jinnee functions
Here’s just a taster of what jinnee offers:

- Iconsfor files, folders and programs on the desktop.

- Drag&Drop.

- Launching up to 50 programs via keyboard shortcuts.
- Output of directories via GEMDOS or NVDI.

- Fast file copy, format, delete and move, optionally using Kobold.
- Automatic window size handling.

- Mac-OS8-style spring-loaded folders.

- Hierarchial folder display in text mode.

- Copying of file lists via menus like Windows95.

- Notepad for Post-it style desktop notes.

- Recoverable wastebin.

- Much, much more...
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2.1.3 System requirements

jinnee runs on all Atari and compatible computers with at least 1Mb main
memory at resolutions from 640x200 pixels (ST-medium) or higher. A hard
disk of some kind is indispensable as floppies have insufficient storage
capacity to hold all the files in the jinnee package, and are in any case too
slow for some functions (such as the recoverable wastebin).

For optimum performance use jinnee as the desktop for the MagiC
pre-emptive multitasking operating system: MagiC for Atari computers,
MagiC Mac for Apple Macintosh and MagiC PC for Windows 95/NT.

Jinnee also works without MagiC so long as WDIALOG.PRG (included in the
jinnee distribution) isinstalled in your AUTO folder.

Important!

Your operating system must support colour icons in order to be able to use
them all MagiC versions support colour icons.

2.1.4 Installation

The installation of jinnee couldn’t be easier GEMSetup takes over all the
hard work!

First of all, ensure you installation disks are write-protected. Then make one
safety backup copy of each disk. Remember that jinnee is commercial
software, so you may not pass copies to anyone else, whether before or after
registration.

Insert Disk 1in your floppy drive, open it by clicking on the Floppy A icon and
double-click on SETUP.APP; you will be presented with a registration dialog.
Enter the serial number that will be found on your disk, and your (and if
appropriate your company's) name and address. (The Demo only button has no
function with jinnee).

After clicking on OK a second dialog appears. Here you should first of all
choose the language you require (presumably English) in the popup at bottom
left. Then double-click on the editable field just above to bring up the file
selector to set the path to where you want jinnee installed. If you only specify
the root directory of a drive, you will be asked whether the installation
should be to a jinnee folder (or you can rename it) on the destination drive.
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The popup at the top allows you to choose which parts of jinnee should be
installed. Normally you will choose the Standard installation. But you can also
customize installation to suit your requirements:

In the central part of the dialog there are three checkboxes, one for each of

the main groups: The Baslc jinnee package, the Plug-ins and Extra programs.
Clicking on the right-facing triangle next to each checkbox pops open a list
of further choices that allows you to select what you want installed in even
greater detail. An item is selected/deselected by clicking on the checkbox. A
cross in the box ensures that this item will be installed. Note that some
entries are linked, i.e. they cannot be installed without one or more of the
others. If you de/activate one of these entries then the other linked ones will
be de/activated as well.

When you have made your selections, click on Setup and in a few minutes you
will find the appropriate files transferred to your hard disk. You will be
prompted to change floppy disks when necessary (on a Mac the first disk will
even be ejected automatically!).

The installer is quite intelligent and when running under MagiC or MinT
reads the “Home” dir and “Magic.inf” files, so it knows the destination paths
of the different files it has to install/update;if a path is not found, you will be
asked for it. When running in plain TOS, you have to set the paths before
starting the installation: Click on the Options button and then Flles & folders to
bring up a dialog where each path may be set manually. If you already have
ST-Guide installed on your system, the installer will automatically put the
HYP and REF files in the folder/path that you have set in the STGUIDE.INF
file.

When the installation is complete, the READMETXT will be displayed.
Please take time to read it it may contain information that was not available
at the time the handbook and hypertext were completed.

After jinnee has been successfully installed copy BUBBLE and KEYWATCH
from the EXTRAS folder to your auto-starting applications folder, typically
a START folder in the path:

CNGEMSYS\MAGIC\

And that’s it! You can now reboot your computer and explore all the many
facilities that jinnee offers.

10
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2.1.5 |]innee and MagiC, MagIC Mac, MagIC PC

Under MagiC an additional box in the setup dialog asks if you would like to

install jinnee as the desktop for MagiC. If your answer is Yes then the file
CAMAGX.INF will have an entry such as

# SHL CAJINNEE\JINNEE.APP

inserted in it. (In fact the path in which you have installed jinnee will be
entered in place of CAJINNEEN\).

2.1.6 Jinnee as an AV-Server

In order for programs to communicate with jinnee via the AV-protocol,
which offers many benefits, the AVSERVER environmental variable must be
set. To do this manually, using an ASCII text editor, add the following entry
on theline following the # SHL entry in MAGX.INF:

# ENV AVSERVER=JINNEE

The SETUP program also offers the option to perform this task
automatically.

2.2 Using jinnee

2.2.1 Standard desktop icons

Icons represent objects such as a device (in this text this term normally
means a hard disk partition or a floppy drive), file, wastebin and so on. The
first time jinnee is launched the desktop displays icons for each device, a
notepad and the wastebin.

Icons can be selected using the mouse, moved around the desktop or between
directories, and opened by double-clicking on them. Icons can be removed
from the desktop by simply dragging them to the wastebin. Don’t worry, the
original files and folders are not deleted, just the icon. Files and folders can
only be deleted from desktop windows.

1
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% Jinnee Object Show Mindow Special Quick
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If you have accidently removed a device icon or want to ensure the drive
icons on the desktop match the devices available, select the Find drives entry in
the Object menu, which will create icons for any devices missing from the
desktop.

To assign icons to files or folders select the Icon manager... option in the Special
menu. This launches Jlcons, a separate program, which takes care of icon
handling.

You will find more about this in section 3.6.4 lcon manager.

2.2.2 Drive contents window display

Double-clicking on any drive icon opens a window to display its contents.
The info—line bElOW the X Jinnee Object Show Window Speclial Quick

window title shows the W A @ @A = Q.

LATTTII T ATTT T 1 IT138 BYF) (EITI0T%s) (Fraehlcs) [Hetepsd) [WNaitsilnd

number of objects El! C:\e &hga: -%(?l 1:\CAB2_8\* Hn '
contained in the window 1,2 RB Iin 78 objects | 681,8 KB In 19 nh]uct: 71,6 NP h:r

w 158168697
\
as well as the space they 0 1 $TGUIDE . APP 120,4 8
occupy on thedrive.In ™ ISTGUIDG.PRG 120,4 KB

O RPEGOSP . TTP 8,3 KB -

addition the remaining ; 256-COLS

free spaceon thedriveis | YAsSIoNs

NUDI2_5 .SYS 1,3 KB

NUDI3_2 .SYS 1,5 KB

shown. NUDI4_1 .SYS 1,0 KB

NUDIS_81.SYS 1,7 KB

If only part of the SYSTRFNT.SYS 1,8 KB
b AUTO

info-lineis visibleitcan | wcaLnsst

bescrolled in real-time b TENT  oar
using a click-hold-drag -
action. On releasing the mouse button the info-line displays the left-most
text again.

If any object/s inside the window are selected, the info-line displays the total
number of objects selected along with the remaining free space the contents
of folders are not taken into account.

In addition to the usual window gadgets several additional buttons have
been added to theinfo-line:

12
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@ This button closes the window immediately. This avoids tedious
stepping up through the directory tree when displaying the contents of
deeply nested folders. The button appears only if Window closer closes
Immediately is not switched on in Speclal > Settings... > Window.

This button switches to the directory level above the present one, or
closes the window if you are already in the root directory of the drive. The

button appears only if Window closer closes immediately is notswitched on
in Special > Settings...> Window.

With this button you can pin down certain window settings to the
current path, i.e. as soon as the path is entered the window will open again
with exactly the same preferred settings. See 3.5.6 Pin. .. for further details.

This button adapts the window size to its contents to make them all

visible without scrolling, where possible. The Adapt option in the Window menu
performs the same function.

and Directories can be displayed as text or icons; both have
advantages and disadvantages. For example, in text mode hundreds of files
can be displayed along with their file size and date-stamps whereas in icon
mode it's easy to display an overview of device contents and pick out
individual objects. These buttons switch between these two modes.

Each of these info-line buttons can be individually displayed or hidden in
the Special > Settings... > Info-line dialog.

The window contents can be navigated item by item (icon or text) using the
cursor keys; holding down the [Shift] key moves the cursor a page at a time.
The [CirHome] key moves the cursor to the start and [Shift] + [CIrHome] moves the
cursor to the end.

If the Cursor keys move selection option is active (crossed) in the Speclal > Settings...
> Autolocator dialog you always have to press the [Control] key as well during
scrolling, as the normal cursor keys move the cursor, i.e. the selection, to the
next object and, if multiple objects are selected, deselects the others. If this
option is inactive, the cursor keys behave like window scroll arrows and
multiple object selections are retained; to temporarily switch to the opposite
behaviour hold down the [Control] key during scrolling.

The typeface used for various objects can be freely selected. When using the

13
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text display mode, jinnee, in addition to the filename, can also display the
file Length, Date, Time and Flle attributes, as well as switch between Multiple- or
Single-column display.

Selecting the relevant menu entries toggles their action a tick shows those
that are active.

The various text window display options can all be selected in the Show

menu (see section 3.4 The Show menu).

Selections made with no window open on the desktop become the default for
windows opened subsequently, though any window can be altered to suit
your preferences once it has been opened.

2.2.3 Hierarchical folder display

This feature, borrowed from the Mac Finder and only usable in the text
mode, displays small triangles (or other user-definable mini-icons) to the
left of each folder. These can be used to navigate subdirectories. Click on any
right-facing triangle (or whatever mini-icon you have chosen to represent a
closed folder) to pop open the folder, which will display its contents in the
same window, indented below the folder name; at the same time the
mini-icon changes to one denoting an open folder (by default a
downward-pointing triangle). A click on this mini-icon closes the folder and
hides its contents again.

Alternatively, the folders may be popped open with [Control] + [Cursor-right] and
closed again with [Control] + [Cursor-left]; this process is made easier if Cursor
keys move selection is switched on in Speclal > Settings... > Autolocator.

This function makes it easy to see what is contained in various sub-
directories, and also to copy or move files in one window between different
directory levels (nested folders).

To move/copy files via Drag&Drop to a popped open folder you must select
the destination folder to drop the files onto using the cursor. Releasing the
cursor over the entries in the destination folder does not work.

14



2.2.4 Autolocator

File/s can be selected using the keyboard. g
Enter the first character(s) of the target file aCt o 50 KB 19.17. 24
and jinee selects all matching objectsin the LT LTSI LA

aqgro2.him 13,8 KB 16:36:16
topped (active) window and auto-scrolls to SSatr gt 2 KB 15:36:02

. . alf.him b,] KB 16:35:080
display the selected files. The characters atfl.qif 5, 15:35:38 Jog
: . . : . atfl.htm S8?7 13:21:24 |
entered are displayed in the window title line atf2.qit B 15

atf2.htm 571 13:21:42 ;ﬁi
after the path. a_ads.htn 1,5 KB 16:33:52 |

After successfully isolating the desired object aindom.tn 4,4 KB 16:33:08

o o a_news .hitm 27,9 KB 16:32:28 |::

pressing the [Return] key will launch a a_post.htn 1,9 KB 16:31:82 |

program, or open a folder or file. If the ‘Return’ o : ’
)

acts only on first selected object option in Special >

Settings... > Autolocator is deselected (uncrossed)
multiple objects can be opened furthermore, these objects remain selected
after they have been opened and the window can still be scrolled.

Hit the [Space bar] to immediately clear the Autolocator entry ready to try
again. Wildcards (“?” and “*”) are supported, but note that the Autolocator
matches objects with look-ahead it treats the entered string as if “*” was
appended at its end unless it is terminated with a semicolon (“;”).

The semicolon “” character can be used in the Autolocator to quickly locate
an exact file match, ignoring objects with similar, but longer, filenames.
Here’s a couple of examples:

Inputting “*TXT” may find, for instance: “TARGETTXT”, “AND THISTXT3”,
“AND EVENTXTI1”.

“*TXT,” skips the TXT3 and the TXT.1 entries and only selects: TARGET.TXT.

Here’s another example:

“FOLDER” may {find: “FOLDER”, “FOLDER_OTHER” “other folder”,
“FOLDER.BAK” “FOLDER2” “foldermk2.BAK”.

“FOLDER,;” skips everything that has something after “FOLDER” and only
selects: “FOLDER”.

2.2.5 Window configuration

Selecting or deselecting As Icons in the Show menu switches between icon or
text display mode (this can be done also by the buttons in the info-line as

15
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described in section 2.2.2 Drive contents window display).

The typefaces used to display the icon or window text can be selected in the
Speclal > Settings... > Fonts dialog. Clicking on each box containing the font
name and size brings up the font-selector where replacement typefaces and
sizes can be chosen.

When displaying windows containing dozens of objects it is sometimes

useful to use the Mask option in the Show menu to hide unwanted objects so
that they do not appear in the window. For example if you're looking for a
program to launch you could enter a mask “*PRG".

Refer to 3.4.2 Mask... for more information.

Objects are displayed in windows in a particular order depending on the
settings in the Show menu. Files can be displayed sorted By name, By type, By
size, By date , Unsorted or Backwards sorted as desired.

2.2.6 Window size management

Most desktops open windows to fixed sizes irrespective of the contents or the
available space on the desktop. This typically means the window has to be
manually resized or scrolled to view the contents. The Adapt option in the
Window menu sizes the window to the smallest possible size which displays

the entire contents. If the Automatic adaptation option in the Show menu is active
(ticked) then on opening every window is automatically sized to suit its
contents.

2.2.7 Long fllenames

From MagiC 5 onwards, long filenames are supported on the Atari platform
without additional software (MagiC Mac and MagiC PC have always
supported long filenames). Naturally jinnee also supports long filenames,
and adjusts the width of directory windows automatically to display the
longest object entry.

Important!

Please remember many older programs do not support long filenames and
this can lead to problems.

2.2.8 Launching GEM programs
GEM programs have file extenders “PRG” or “APP” and normally include

16
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dialog boxes and a menu bar as their user interface. GEM programs can be
launched from the desktop using the mouse by double left-clicking on the
icon or text. In the Speclal > Settings... > Mouse clicks dialog you can arrange for
the double-click to be simulated by another mouse action such as a single
right-click, or a key combination.

As many desk accessories (extender “ACC” ) also run as GEM programs, you
can launch them in jinnee like a normal program, or install them
subsequently in the menu. Incidentally, deactivated desktop accessories,
typically renamed with “ACX” file extenders, can also be launched from the
desktop.

MagiC versions up to 4 run desktop accessories as normal GEM programs,
which means they are not installed in the left-most menu alongside the
desktop accessories installed at boot time.

With MagiC from version 4 onwards desk accessories are no longer launched
as a program, but can be installed as accessories at any time; they will appear
in the left-most menu with the other desk accessories and can be launched
from there. If you select an accessory entry in the menu while holding down
the [Control] key, then under MagiC the accessory will be unloaded again.
(Note that this does not work with some accessories that hook deeply into the
operating system, such as Harlekin, for instance unloading these will cause
the computer to crash soon afterwards, necessitating a re-boot.)

Another way to launch programs involves dragging and dropping icons (or
filenames in text display mode) onto each other usually referred to as a
Drag&Drop action. For example, if you Drag&Drop a text file onto a text
editor object (icon or filename), the editor will be launched displaying the
file ready for editing. Behind the scenes jinnee passes the filename to the
text editor as a parameter, which works so long as the application supports
parameter passing most modern GEM programs do, so try it out for yourself.

You can learn more about starting programs and parameter passing in
section 4.24 Specilal > Settings... > Program start.

Programs can be launched using a keyboard combination specified in the

Applications dialog accessed from the Speclal menu. Selected object/s in the
currently topped (active) window are passed to the application so long as the
Pass selected objects option in the Applications dialog is active.

Under MagiC it’s also possible to Drag&Drop additional files onto the icons
of currently running applications which support the AV-protocol VA_START
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command which happily includes most modern GEM applications.

If you would like to be asked before parameters are passed, disallow
parameter passing or set other program start options as follows:

To set global program start options refer to: 4.24 Speclal > Settings... > Program
start.

For application-specific start options refer to: 3.6.3 Special > Applications....

2.2.9 Launching Mac programs

Under MagiC Mac you can launch Mac programs directly from jinnee. To do
this the drives from which you wish to start Mac programs have to be
entered in the Mac programs on: line of Special > Settings... > Programs.

Mac programs will be recognised on the corresponding installed drives and
you can start them just like GEM programs with a double-click. jinnee then
automatically switches over to the Mac-OS side and starts the program.

2.2.10 Launching TOS programs

Programs with the file extender “TOS” or “TTP” are TOS programs. Unlike
GEM programs, which can output a combination of text and graphical
objects, TOS programs only support input/output of text. TOS programs can
be launched like GEM programs and in some cases can also be passed
parameters. (Note that the TOS extender is also used for self-extracting
archives where there is no input, nor any output to the screen while they are
unpacking apart from possible error messages).

TOS programs are commonly used to convert files from one format to
another and therefore expect the filename(s) to be passed as parameters.
Such programs are typically the “T'TP” (TOS Takes Parameters) variant.

0| Poremeter possing Bla

EX\DISK\ARCHIVER\ARC\RRC.TTP

On launching a TTP program jinnee displays this dialog box where
parameters can be entered into the editable field.

The parameters entered into the editable field are passed to the program by
Jinnee. If you click on the command line the file selector will be displayed
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and can be used to select a file which will be passed to the program.

TTP programs launched by Drag&Dropping are automatically passed
parameters without user interaction unless the Open TTP dlalog box In Drag&Drop
operations option is active (crossed) in Speclal > Settings... > General.

2.2.11 Command line variables

jinnee mixes any command line variables with the additional parameters
(objects) to create the final command line passed to the program. Without the
command line the parameters are passed directly. Apart from this,
parametersonly play a role if they are referred to by variables.

Some example variables are listed in the jinnee hypertext.

2.2.12 File copying

To copy a file simply Drag&Drop the file icon (or name in text mode) on the
destination folder. It’s possible to drag icons (or names) between windows to
copy files to other paths. Folders and drives/partitions can also be dragged
just like files. Check out the possibilities offered by jinnee spring-folders
which make it easy to copy files to subdirectories. More details in section 2.3

Spring-folders.

Before jinnee starts the actual copying
process, a dialog box appears which details

— - =

(O] == cCopy objects ==

DAST_GUIDEAGUIDES\
I Tiles

the number and size (in bytes) of 8 folder (s)
files/folders to be copied along with other ® Links
copy options which affect the way the copy 51.349 bytes

operation is carried out.
EBI‘IMB ob jects

Backup mode
Replace all

A growing bar makes it easy to monitor L
the progress of the operation.

If a file of the same name is already present in the destination directory, the
following dialog appears and offers various options to resolve the conflict:
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This dialog appears if the destination |G Neme conflict
path contains a file/folder with the SASCRIPT & ol onistsl
same name as one being copied. - Enlsting object
ADRESSEL.STH

Rename 5.578 Bytes Date: 17/82/2088

Timne: 8B:11:14
Enter a replacement name in the New ~ New ob Ject
object editable field and then select RORESSE. STH . -
this button to rename individual 7210 Bytes Tine: | 09:11304
files as they are copied to their
destination. When copying several
files at a time, or folders, you will

have to enter a replacement name
each time a conflict arises, or select one of the other options.

Replace

Select this option to overwrite a file in the destination path which has an
identical name to the file being copied.

Skip

Select this option to skip over a file for which an identical file exists in the
destination path (meaning that the file is not copied).

Skip all

No files with matching names will be copied to the destination.

Replace all

Select this option to overwrite all files in the destination path which have
identical names to any of the files being copied without asking permission
to overwrite each individual file.

When folder name conflicts are encountered, entire folders are not actually
replaced; instead jinnee simply copies files from the source folder to the
destination folder.

2.2.13 Flle moving

Often it is more convenient to move files/foldersin a si ngle operation instead
of carrying out separate copy and delete actions. To move files hold down the
[Control] key during Drag&Drop operations.
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2.2.14 File copying with renaming

To rename files/folders during copy operations hold down the [Alternate] key.
See also 2.2.15 Symbolic links.

2.2.15 Symbolic links

Instead of moving a folder or file to another directory, you can leave it in
place and create a symbolic link to it. A symbolic link (also called an “alias”)
is similar to a short file containing just a pointer to the original file or
folder with its path, and so occupies minimum space on the disk. Its name
will appear in italics in the destination directory window, both in text and
in icon mode.

When a symbolic link is accessed (be it as a file or as a portion of a path) its
destination will be read internally and its filename replaced with the real
file. So clicking on a symbolic link object or using it in Drag&Drop
operations gives the same result as if it had been applied to the original file
entry.

Symbolic links are created when files are moved holding down the [Shift] +
[Alternate] or [Shift] + [Control] key combinations.

If the Create links with ‘Alternate’ option in the Speclal > Settings... > Copying dialog is
active (crossed) then only the [Alternate] key needs to be held down. However,
with this option active, file copying with renaming using the [Alternate] key is
no longer possible.

Symbolic links may be deleted by dragging the italicised entry to the
wastebin (the file itself will not be deleted, just the link). Note that if the
original object is deleted, or moved subsequently without setting up a new
symbolic link, the link is no longer valid and is shown greyed out; such links
may be cleared off the disk by dragging them to the ‘real’ wastebin.

2.2.16 File deletion

Files and folders are deleted by dragging them to the wastebin or by
selecting the objects followed by the Delete... option in the Object menu. Before
deletion begins a confirmation dialog is displayed.

If the confirmation dialog becomes annoying it can be turned off in the
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Speclal > Settings... > Copying dialog.

Important!

With the confirmation dialogs turned off it’s easy to accidentally delete
important files/folders and it is not the recommended setting for beginners!

2.2.17 Recoverable wastebin

One way of avoiding accidentally deleting files/folders is to use a
recoverable wastebin, from which they can be rescued and copied back to
their original (or other) destination again if required. In that case, using the
delete function no longer really deletes the files/folders; instead they are
moved to a drive or folder where they collect until finally deleted or
recovered. Because the files/folders are not actually deleted they still occupy
hard disk space until the recoverable wastebin is emptied, which really
clears the files off the disk once this happens they can no longer be restored,
of course.

The path to the drive or folder used as the recoverable wastebin is set in the
Wastebin edit field of Special > Settings... > Paths. By default the Delete... option in
the Object menu (or [Control] + [Delete] keyboard shortcut) deletes the selected
files/folders off the disk, but if the Use with ‘Delete...’ menu Item option is active

(crossed) in the Paths dialog then files/folders are moved to the recoverable
wastebin instead.

After setting up a recoverable wastebin, use the Icon manager.. from the
Special menu to assign a suitable icon to the drive/folder and then place it on
your desktop.

If Show real wastebin is active in the Paths dialog box then the normal,
non-recoverable wastebin icon will also be shown on the desktop, so you can
really delete filesimmediately by dragging them onto thisicon.

2.2.18 KOBOLD

KOBOLD is a file copying program published by Application Systems
Heidelberg. With suitable options set in Speclal > Settings... > Kobold jinnee can
divert copy/move/delete operations directly to Kobold, which is usually
faster than the desktop functions if many files are involved.
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2.2.19 Specilal copy options

It is possible to simultaneously copy/move/delete files/folders from multiple
windows or pass them as parameters to an application. Normal Drag&Drop
operations affect the selected object/s in a single window. However if the

[Shift] key is held down all selected objects in all windows will be affected.

2.2.20 Copying a la Windows

Jinnee, like Windows95, can copy files between windows using the clipboard.
First object names (not the actual object/s) are copied to the clipboard using
[Control] + [C] or the Copy option in the Object menu. These objects can then be
copied into any window using [Controi] + [V] or the Insert option in the Object
menu. The object names are stored in the clipboard using SCRAPTXT. This
file may well be overwritten if you use the clipboard with another

application before copying the objects, in which case the copy operation will
fail.

2.2.21 Flle display

The application/s used by jinnee to display files is set in the Speclal >
Applications... dialog. The default viewer is the second entry and defaults to
MGVIEW which is supplied with MagiC.

If a file is launched with the [Alternate] key held down this viewer is used to
display it even if a specific application is installed to handle this filetype.If a
file islaunched and no application has been installed to display it the default
viewer is used.

Additionally every installed application supports a number of file masks. If a
matching file mask to display a file is found, this will be used in preference
to the default viewer.

2.2.22 Flle/folder icons on the desktop

You can drag files and folders from a directory window to the desktop where
they will appear as icons irrespective of the original using a text or icon
display. This is useful to provide access to the object even when the window
has been closed. For example, if you drag an executable program from a
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window to the desktop, its icon stays there after you let go of the mouse
button, and remains accessible even after closing the window. A double-click
(or other button combination set up in Speclal > Settings... > Desktop) on the icon
launches the corresponding program.

The object can also be copied by dragging the desktop icon to the destination
icon or window. In a similar way file/folder icons can also be placed on the
desktop.

To remove icons from the desktop simply drag them to the wastebin. The
original object will not be deleted!

Programs on the desktop can also be launched by dragging icons or
filenames onto them. Refer to 2.2.8 Launching GEM programs for more details.

To retain the icon layout on the desktop for use in future jinnee sessions use
the Save desktop... option from the Speclal menu.

To locate the original directory for any desktop icon double- or right-click
the mouse on the icon while holding down the [Alternate] key.

2.2.23 Object groups

No special provision for object groups is included in jinnee because the same
functionality can be provided using symbolic links. To create a pseudo
object group create a folder then create aliases of the desired objects by
holding down the [Shift] + [Alternate] key combination when dragging the
objects to the folder.

Important!
Under MagiC PC aliases only function when using drive containers.

2.3 Spring-folders

Most of us organise our files into folders inside nested folders because this
makes them easy to locate and manage. This hierarchical structure means
data files are often located in different subdirectories inside different
folders, often on different drives. The disadvantage of this structure is that
in order to move files between subdirectories from the desktop requires
repeated opening and closing of folders to locate the desired files. jinnee
offers a solution, borrowed from Mac-OS8, called spring-folders, which
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makes it possible to open subdirectories in a single mouse drag action!

Spring-folders are switched on by entering a value other than “0” for Folders
spring open after: x ms at the bottom of the Special > Settings... > Dragging dialog,
where you can also choose whether folders should open as popups (with text
listings only) or, by activating the Spring folder with real windows option, as real
directory windows (with icons or text entries). Once activated, dragging and
holding an object over drives/folders will open windows to the drive/folder
under the mouse cursor after the set time delay in milliseconds has elapsed.

== F:\DURPS\+ == B, |E ‘DI :\e [
. . . . 12,3 KB in 1 sel . 5,4 AB in 31 objelD}
In the first illustration, the file n 1 seleqdl e
. ) ARTHRDEN
APPLIKATIMG 1S dragged tO the AUTeLDC . (DO Atert 8 bit downloads
. ‘ BUBBDEROD . ) Ciwread e
I'lght WlndOW. BUTBACK . -4l O Enpresso
BUTCLOSE . ING 106 | ]| OO Falcon circuits
BUTICONS . ING 186 [ }| OFTP
BUTIDEAL . ING 186 | ]| O Gemes
BUTPIN . IRG 186 | }| O Ghostscript
BUYTEHT .IMG 106 | -§| OO6T-LO0K
DAUCKEN .IMG_ 3,3 KB |
& -o

A:\»
%' 8 Bytes In |

In the second illustration the
mouse pauses over the “Archive”
folder until a window OpPeIs. ::;:Eg:n . IMG I::: :: 3

(DO Atar! B bit downloads
(JLinread

BUTBACK .IRAG 186 | J| O Enpresso
BUTCLOSE . IRG 186 | §J| O Falcon circulls o
BUT ICONS . IRG 186 I CYFTP |2 5
BUT IDEAL . ING 186 | ]| O Gomes i
BUTPIN . IRG 186 | O Ghos tscript
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The third illustration shows the opened Archive folder;if the folder contains
other folders these can also be opened by pausing over them with the mouse

until the %‘E F:\DURPS\+ == |B|a|B}||O N:\e .Hh][a B} 0 M:\Archive\s _
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If you find the automatic opening of folders disconcerting you can
alternatively enter “0 ms” in the Dragging dialog which disables the auto
opening option, but you can still continue to use spring-folders: After
moving your selection over the destination folder so that it is selected, press

any key, for example the [Space bar], to open the folder.

After the copy operation has been completed any windows opened by the
spring-folder action automatically close themselves again. If during a
spring-folder drag action you would like a window to remain open, press the
[Tab] key. Alternatively, the window opened last (the “destination” window)
can always remain open by activating Keep destination window open in the
above-named dialog box.

To abort the process press both mouse buttons or the [Esc] key useful for
single button mouse users.

If you inadvertently open a folder, you can travel back up the directory tree
to the parent folder by dragging over the “” symbol, or move the mouse
outside the destination window and pause until the window closes itself
again.

In addition to folders in windows, the drag action can also use any folder or
drive icon on the desktop.

If the destination window does not display its entire contents, move the
mouse near the window border and jinnee will scroll automatically:.

2.4 Notepad functions

If you find your monitor and desktop covered in small sticky fluorescent
notelets here’s an environmentally friendly alternative. Using the notepad
you can place reminder notes directly on your desktop, which offers other
advantages:

- You can select any colour from the available palette
- They won't fly away when you open the door!

Now to the practical part: A desktop note is created by selecting the Special >
Notepad... menu entry or, if the Notepad Icon on desktop option is active (crossed)
in Speclal > Settings... > Notepad, by double-clicking on the desktop notepad icon.

If you have the EDITOBJC.SLB shared library installed, you can enter lots of

26



Basics

text in the upper area of thedialog boxand |2 Notepad
the editable field automatically scrolls. E::";m mage

Without EDITOBJC.SLB installed, up to five Jinnee screen dumps
40 character lines of text can be entered. If

you need to enter more text you can use an Font:
external editor that is able to communicate p""':';;“ ::tr.% | N::“ cotour: (I
with jinnee via the OLGA-protocol. More on n windou "
this ability later..

[ ] [concet]

Important!

EDITOBJC.SLB should only be used from MagiC 6 onwards because the
MagiC 5.20 release unfortunately contains a minor error.

The dialog also lets you choose how the desktop note should look:

Font: This popup can be used to select the desired typeface which is to be used
in the desktop notes.

Paper colour: This popup displays a palette from which the colour of the note
“paper” background can be selected. The small white crossed box in the
palette has a special function: It attempts to automatically select the
nearest available colour in the active palette to the “real” pale yellow.

Text colour: This popup selects the text colour.
Edge thickness: This editable field sets the border thickness in pixels.

In window

Active (crossed): Notes are displayed on the desktop in true GEM windows
rather than directly on the desktop, which allows them to be topped (i.e.
placed “in front” of other windows).

Inactive: Notes are displayed directly on the desktop.

Map pin: The map pin can be dragged within its window to indicate which
part of the note is pinned in position. This plays a role if the note text is
changed later so that the size of the note itself changes as well. For
example, adding text to a note pinned in the middle causes the note to
grow in all four directions. Adding text to a note pinned in the top left
corner causes the note to expand to the right and downwards.
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Delete: The corresponding desktop note is deleted. This button is naturally
not selectable until a note has been created.

Normal: This button save the current settings as the default settings which
will be used for all subsequent desktop notes. The default settings are also

changed if you exit the dialog without entering any text via the OK
button. To permanently save the settings the desktop must still be saved.

OK: This button closes the dialog and updates the current note.

Cancel: This button closes the dialog without changing the current note.
The content and position of desktop notes are immediately stored

automatically (in a file called JINNEE.NOT), so you do not need to save
any additional parameters before switching off the computer.

Editor: This button can be used to edit notes via an external text editor. This
offers more flexible text entry and the convenience of a familiar working
environment instead of the Notepad dialog.

To use this feature under a multitasking OS we recommend OLGA be
installed, in which case the application opened depends on the file
extender set in the OLGA-extension option in the Speclal > Settings... >
Notepad dialog.

jinnee communicates with OLGA via the OLGA-manager. Using OLGA
offers the advantage that notes on the desktop are updated immediately
on saving the text in the text editor.

ITf OLGA is not installed, jinnee’s default editor as installed in the Speclal >
Applications... dialog is used instead, and changes to notes take effect after
exiting the text editor.

Once created the desktop notes can be dragged in real-time using the
mouse which makes it easy to see exactly where the note text ends up. If
the note is released over a free area of the desktop the note is simply
moved to the new position.

If the note is dragged onto a window or another application, jinnee
attempts to communicate with this application via the Drag&Drop
protocol. Normally this results in the note being inserted into the
document.

Dragging a note onto a folder or into a jinnee directory window causes
jinnee to save the note asan ASCII file called INOTETXT.
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Desktop notes can also be merged via Drag&Drop by dragging one note
atop another. In the Speclal > Settings... > Notepad dialog you can restrict this
to occur only when the [Shift] key is pressed by activating the Merge notes
with ‘Shift’ checkbox.

Desktop notes dragged to the clipboard (normally CACLIPBRD\) are
saved in the clipboard in a file called SCRAPTXT, which can be pasted

into other applications using the standard [Control] + [V] keyboard shortcut.

Drag&Drop operations also work in the opposite direction with other
applications which support the Drag&Drop protocol. For example,
Drag&Dropping a URL onto the jinnee desktop from CAB creates a note
containing the URL.

To edit existing notes, double-click on the desired note and it will appear
in the upper area of the Notepad dialog ready to edit.

To delete a note either drag it to the wastebin, or hold down the [Control] +
[Alternate] keys and double-click on the note to be deleted.

Holding down [Control] when double-clicking on a note sends the text
immediately to the installed OLGA text editor.

Note tags: For advanced users: The individual lines in the notes can be
assigned different settings for, say, font and colour. This can be achieved
directly in the text with the following “tags”, but be careful not to change
their syntax:

- #F <font>: Usenew font; <font>isID or name

-  #P <pt>: Use new font size; <pt>issize in points

- #C<color>: Usenew text colour; <color>isindex
-1=pale yellow

- #Cent: Centre text lines

-  #Left: Leftjustify text lines

Tags are only recognised at the beginning of lines and must be placed on a
line of their own. The tag entries are valid for all following lines. Exactly

how tags are handled can be configured in the Speclal > Settings... > Notepad
dialog.
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2.5 Extra programs with JInnee

The jinnee distribution includes several optional extra programs in the
EXTRAS folder. The installation of these programs is described in the
accompanying documentation. One or two are standard desk accessories or
GTP programs, but most will need copying to your auto-starting
applications folder, from which they will be installed after rebooting the

system.

Under MagiC the exact path of the auto-starting applications folder is
specified in the editable ASCII file MAGX.INF, next to the # APP-entry. By

default it is:
CN\GEMSYS\MAGIC\START\

2.5.1 MENU3D

3-dimensional look to menus and sub-menus.

After launching MENU3D.PRG all menu bars and sub-menus adopt the
3D-look, where the operating system supports this feature.

This program is not required with MagiC 6 or later.

2.5.2 SYSSOUNDS
Window shading sound effect and different system ping.

SysSound only works if the XBIOS sound routines of the Falcon are
available, otherwise this utility has no effect. It also works under MagiC Mac

if the MSND.PRG/MACSOUND.PRG utility is installed, because this
emulates the necessary routines.

SYSSOUND.PRG installs three system sounds one for the operating system
Ping! and two for the MagiC window shading feature. To install SysSound,
just copy the program together with the three sound sample files (PING.SMP,
SHADESMP and UNSHADE.SMP) into the MAGIC\START folder The
samples have to be in 8-bit mono and play at 25KHz. If a sample is missing the
corresponding routine will not be installed, which means you can leave out
the ping or, if youre not running MagiC, the window shading samples.

30



Basics

2.5.3 POPFOLD

Older jinnee versions were accompanied by a program called “Pop Fold” that,
when run, made double-clicks on the desktop display a popup menu showing
all available drives and desktop objects. This could then be used to navigate
the directory tree (opening drives, folders and launching applications). This
program is no longer required by jinnee itself from version 2.0 onwards, as
the popups are incorporated in it (though it may be needed by other
programs that make use of its functions).

2.5.4 KeyWatch
Offers application-independent keyboard shortcuts.

After launching KEYWATCH.PRG, it monitors keyboard input for the

[Control] + [Alternate] + [key] combinations and interprets these to launch
applications installed in jinnee for these shortcuts even when jinnee is not
the current foreground application.

For example, with CAB (the popular HTML browser) installed as an
application under jinnee with the QuickStart key combination [Control] +

[Alternate] + [C], CAB can be launched at any time even if another
application is topped.
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3 The jinnee menus

3.1 The drop down menus

Most of the menu entries have keyboard shortcuts that allow menu items to
be accessed by pressing a combination of keys instead of clicking on them.
The ~ character represents the [Control] key and the upward-facing arrow the

[Shift] key.

jinnee: Containsimportant copyright and version number details.

Object: Includes all file operations and output options.

Show: Configures how window contents are displayed.

Window: Operations which affect window display.

Speclal: Configures the jinnee user interface and sets global user options.

Quick: Offers a menu where applications can be included for easy access.

3.2 The “jinnee’”’ menu

3.2.1 About Jinnee...

The About dialog contains the version number, your registration details and
the jinnee copyright information.

3.3 The “Object”’ menu

3.3.1 New object... AN

Use this menu option to create a new object in the path of the topped window.
A dialog appears where the name of the file or folder to be created can be
entered.

3.3.2 Open AO

This menu option opens the selected object/s in the top window. If no object is
highlighted, any selected object/s on the desktop are opened instead.
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The Open option has the same effect as double-clicking on an object. Multiple
objects can be opened and, under MagiC, multiple programs can also be
launched.

3.3.3 Information... Al

A dialog displays detailed information about each selected drive, folder or
file in the toped window. If no objects are selected in the top window a
summary for that drive or partition is displayed instead. If no directory
windows are open but desktop object/s are selected, information for each
desktop object isdisplayed in turn.

The “Information” display for drives and folders includes Details and Overview
buttons. The Detalls button causes jinnee to ascertain the total bytes, number
of files, folders and links. This information is optional because it can take
some time to calculate and if you just want to rename a folder this
information is not required. The Overview button displays the total bytes,
number of files, folders and links. Although this button is available for single
objects, it only provides additional information if two or more objects are
selected.

Folder information:

A dialog displays detailed information about the selected folder/s in
windows, including the folder name which is editable as well as date and
time entries. By default these display the time/date-stamps the folder was
last modified, but you can choose three different options from the popup
(note that it depends on the file system in use whether this information is
provided correctly):

- Created Date/Time: When the folder was created.
- Modified Date/Time: When the folder was last modified.
- Accessed Date/Time: When the folder was last accessed.

In addition, folder attributes and access rights are displayed. Whether these
can be altered will again depend on the file system in use.

Detalls and Overview buttons are also provided. Select the Detalls button and
jinnee ascertains the total bytes, number of files, subdirectories and links
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contained inside the selected folder. This information is optional because it
can take some time to calculate and if you just want to rename a folder this

information is not required. The Overview button displays the total bytes,
number of files, folders and links of the selected objects in a separate dialog.

Although this button is available when a single folder is selected, it only
provides additional information if two or more objects are selected.

Flle Information: N \ceb. 2 Tmodutes . ‘
A dialog displays detailed I“du“;:;:ﬁz Byla:— nut;: |5f|zn_9;_9
information about the selected file/s  Files Time:  20:29:88
including the filename which is ® Links __Modified ]
editable as well as date and time - Rttributes

entries, for which you can choose E ET::.:" ! a i&':.iﬁ,

three different modes from the
popup (note that it depends on the
file system in use whether this
information is provided correctly):

| ~ Access rights

08 BoE oonn l
Onei Py 8 ¥ Sroup = Others

L —

- Created Date/Time: When the file was created.
- Modified Date/Time: When the file was last modified.

- Accessed Date/Time: When the file was last accessed.

The dialog also shows the file attributes:
- Read only
- Hidden
- Archive
- System
and these may be set (box crossed) and cleared as desired.

Under MagiC Mac the Creator and Type can be edited as well, but only change
these if you know what you're doing!

In addition, with suitable file systems the access rights of files can be
displayed and manipulated; such file systems exist at present almost
exclusively for MiNT. Set attributes are shown as selected (in inverse video).
Clicking on a field to deselect it clears the corresponding bit.
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Executable files can have their
) C:\COPS.ACC
program flags and fastload bits |meg ——
modified, which determine how | [ bociaimi | 47,126 sytes Dete:  30/00/19%0
memory is used when launching | gesaurce fork: " 8 bytes —edities ]
programs: ~ Attributes ~ Progrom flags
) | Read Only System Fastload
Fastload: If this option is active Hidden Brchive Loed n IT-heR
| | creator: [Ronc| Type: [TEWT Aalloc In TT-RAR
(crossed) programs are loaded Mininal Heap
. ~ Access rights Private | [] Shered
into memory faster. Almost a.ll onn GoD Gnn — L
modern programs support this ouner  dreus | Swhers
feature, so only disable it if you
encounter problems. B — —

Load In TTRAM: If this option is active (crossed) programs are loaded into the
fast TT memory, where available.

Malloc in TTRAM: If this option is active (crossed) the memory allocation for
programs is satisfied from fast TT memory, where available.

Minimal heap: This sets a given bit which is required, for instance, for
development of Shared Libraries for MagiC 6. You should not set this bit
for normal applications.

The following flags/options are only of interest to users of systems running
MiNT:

- Private

- Global

- Super

- Read only

- Shared option

The Limit option can be used to reserve a fixed amount of memory for (mostly
older) programs which try to grab the entire available memory when started,
such as First Word Plus, Adimens, Signum!2, STAD, and so on.

An Info button is also provided which displays the total bytes, number of files,
folder and links of the selected objects. Although this button is available
when a single file is selected, it only provides additional information if two
or more objects are selected.
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Desktop icon information:

An icon normally has a text (its title) surrounded by a small box (the icon
“flag” or “banner”) below its image for identification. This text is usually the
filename, but can be edited by selecting (highlighting) the object, then using
the Object>information... menu entry and entering the desired text on the Title
line in the resulting dialog box. Some users prefer to remove the icon title
text completely and naturally jinnee allows this: Simply press the [Esc] key
to clear the edit line.

Theicon title can be altered in various ways:

Font: The font used to display the icon title can be freely selected in Speclal >
Settings... > Fonts. Vector fonts are supported.

Colour: The colour used to display the icon title can be selected from the

available palette in the Banner colour popup in Speclal > Settings... > Icons, or
alternatively the text can be displayed on a transparent background by
selecting the small crossed square from the top left corner of the palette.

Slze: The point size used to display the icon title can be freely selected in
Speclal > Settings... > Fonts.

Frame: The size of the frame surrounding the icon title, along with an
option to display the frame outline, can be specified in Speclal > Settings... >
icons.

The Desktop Info dialog also includes a Single click opens checkbox option
enabling each desktop object to be opened with a single click, and Open as
popup that makes drives and folder contents appear in a popup in place of a
directory window; by holding down the [Control] key you can switch to the
alternative display when opening.

D"W |nf°rma“°n: Drlua information

Title:
A dialog displays information Label :
about the selected device (drive or Orive: ¥ 175,367,552 bytes used
partition) including its icon Title B Single click apens 929,628,168 bytes totel
and volume Label, which can both p« , m:s:apugm 72 vect/ctuster

] : 1,277 i1 16,384 bytes/sect
be edited or cleared as desired. . rolae ytes/sector
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Select the Detall button and jinnee ascertains the total bytes, number of files,
folders and links. This information is optional because it can take some time
to calculate and if you just want to check how much remaining free space a
drive has thisinformation is not required.

If no drive icon is selected but a directory window is open, the drive dialog
shows the information for the top window in this case the icon title cannot
be edited because it’s a window.

3.3.4 Copy AC

Select this menu entry to copy the selected object/s in the top window to the
clipboard. Object/s can be pasted into any destination directory using the
Object > Insert menu entry.

important!

The object names and not the objects themselves are copied to the clipboard
to a file called SCRAPTXT. If another application uses the clipboard

Copy/Move/Insert options before you paste selected objects to their destination,
the object names will be overwritten. The object information is stored in
SCRAPTXT as pure text, such as, say:

CNJINNEE\DEFAULTS\
CNJINNEE\JINNEE APP

As editable ASCII these entries can be manually edited or pasted into
applications using the standard clipboard functions.

3.3.5 Merge [Shift]AC

This menu entry works much like Copy, except that the paths and filenames
will be appended to an existing list in the clipboard i.e. the previous
SCRAPTXT will not be deleted.

3.3.6 Insert AV

Copies object/s previously stored in the clipboard using Object > Copy or
Object > Merge (or placed there by another application) to the top window.
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3.3.7 Delete... A\DEL

Deletes the selected object/s from the top window. If a path has been set for a
recoverable wastebin under Special > Settings... > Paths and its Use with ‘Delete...’
menu item option is active (crossed), the object/s are moved to the recoverable
wastebin instead of being permanently deleted. To permanently delete
object/s in the recoverable wastebin select the Speclal > Empty wastebin menu
option.

3.3.8 Select all AA

All objects in the top window are selected. If no window is open all desktop
objects are selected instead. A click in the window or on the desktop
respectively deselects them once more.

3.3.9 Find... AF

This menu entry calls a user-defined external search utility program. By
default MGSEARCH, bundled with MagiC, is installed. Recommended
external programs include:

- FINDER by Holger Weets
- SUJI by Daniel Hopfl

Searching begins on the selected drive, or the topped window. The search
program can be specified in the Speclal > Applications... dialog: It’s the third
entry ( Finder).

Important!

Unless you are using the standard TOS 8+3 character file system, “**” will no
longer display all objects instead only files with at least one “” in its filename
will be displayed; this means that something like README would not be
found. So if you wish to find all files under systems supporting long
filenames you have to input “*’ instead, and for finding all files that start
with “Image” you have to input “Image*”.
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3.3.10 Print... AP
Prints the contents of the top window, or all selected objects.

10 Print B|a
The filenames and path are passed. In the C® e
Print dialog you have the choice to output via E Conger ¢ "
GEMDOS or GDOS (N'VDI). Pegelength: 65 ines
- O 6oos

UbDl device number: 21
GEMDOS Font: Times New Romen lopt
Characters are passed as ASCII codes to the [ x|

printer. The following options are available:

Form feed: If thisoption isactive (crossed) the printer will eject the last sheet
afteritis printed.

Convert B characters: Unless this option is active (crossed) the “B” characters in
the Atari ASCII character set are likely to be substituted by a different
character on output. This is because most fonts are designed for use on
other platforms and have a different layout for characters above ASCII
127. Activating this option causes jinnee to substitute Atari “B” characters
so they appear as “B” s on the printed output. This option is obviously of
interest to anyone handling German text.

Page length In lines: Enter the number of lines in the editable field that will fit
on a given page-size with your printer (this may have to be established by
trial the first time you use it).

GDOS

If GDOS (NVDI) output is selected the page is passed to the specified GDOS
device by entering its VDI device number in the editable field.

To check which device drivers are assigned to which VDI device numbers
take a look at your ASSIGN.SYS in an ASCII text editor. ASSIGN.SYS
normally resides in the root directory of your boot partition.

Font: Click on the large button to bring up the font selector, in which you can
select the font to be used for output. Vector fonts are supported where
available.

Print: Select Print to commence output.
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OK: Exits the dialog and saves the settings without printing.
Cancel: Exits the dialog without printing or saving any changes.

3.3.11 EJect media AY

Select this option and jinnee tries, in the following order until successful, to:
- Eject the media from any selected drive/s.

- If no drives are selected, eject the medium from the drive to which the
topped window belongs.

- E)ect the disk from drive A: (this works only if supported by the
hardware, e.g. under MagiC Mac).

3.3.12 Find drives

Searches for all drives/partitions that the operating system recognises and
mounts icons for each drive on the desktop. Icons for any devices which are
no longer mounted or recognised by the operating system are removed.

Exceptions can be configured in Speclal > Settings... > Drives.

Note: When Always show new drives is activated in that Drives dialog, this menu
entry will usually no longer need to be used.

3.3.13 Format...

Select this menu entry to format floppy disks. The MagiC utility
MGFORMAT is called by default, which includes an option to clear a
previously formatted disk which is much faster than re-formatting.
Alternatively any other suitable utility can be configured to handle

formatting operations in the Special > Applications... dialog. The fourth entry
(Formatter) is devoted to format operations.

3.3.14 Quit AQ

Select this option to exit jinnee. If jinnee is installed as the desktop under
MagiC then jinnee will be immediately restarted.
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3.3.15 Shutdown [ALT]+[SHIFT] Q

Select this option to close down the operating system and cleanly exit all
running programs. This option should avoid any data loss which could occur
if the computer is simply switched off. For a more detailed explanation of
the shutdown procedure refer to the MagiC documentation. Selecting this
option under MagiC Mac exits to the Mac Finder. Selecting this option under
MagiC PC exits to the Windows desktop.

Under Speclal > Settings... > Program start you can choose whether or when the
current jinnee settings are saved automatically.

MagiC’s SHUTDOWN.PRG is used by default, though if you would prefer to

use a suitable alternative program this can be configured in Speclal > Settings...
> Paths.

3.4 The Show menu

If no window is open, any settings made in this menu are used as the default
settings for any windows opened subsequently. Note that subdirectories will
retain the settings of their parent directory if they are opened in the same

window (i.e. when in the Settings > Window dialog you haven't activated Open
folders in a new window; if this has been activated, holding down the [Alternate]
key while opening a folder temporarily forces the opposite behaviour).

If a window is already opened, any settings made in this menu affect this
window only other windows are not affected.

3.4.1As icons AB

This menu entry toggles the display of the current directory window
between icon and text display.

3.4.2 Mask... AX

Masks provide a useful way to select which files are displayed in directory
windows. For example, masks can be used to display all files beginning with
“Sig” or all files with the “TXT” file extender.

To set a mask select Show > Mask... and the Mask dialog box appears.
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There are several alternative options available:
- Enter a mask directly into the editable field.

- Single-click on the Predefined mask popup to select from any pre-defined
masks; the selection made will be displayed in the editable field.

- Double-click on the popup menu, or hold down one of the modifier keys
[Shift], [Control] or [Alternate] while single-clicking on it; this will bring
up a list showing all available file-types in the currently topped
directory window. Any selection made from this will be displayed in
the editable field.

Masks in the editable field can be added to the popup for future use by
single-clicking on the Predefined mask popup and then selecting a free - Set
mask - slot.

Entries can be removed from the popup menu by holding down the [Control}
key and clicking on the entry to be removed.

Using the Speclal > Save desktop... option stores the pre-defined mask details for
future use.

3.4.3 Fliter [SHIFT]AF

This menu entry toggles the filter for the top directory window:. If the filter

1s active, any objects specified in the Speclal > Settings... > Filter dialog are not
displayed. In practice this option is primarily of interest to users of MagiC
Mac and MagiC PC who allow MagiC to read Mac or PC directories directly.
For example, under MagiC Mac files such as the Desktop DB or Appleshare
PDS, and similarly under MagiC PC FINDER.DAT can can be filtered out.

If any files have been filtered out in an opened directory, this will be
indicated by a small filter icon in the shape of a funnel in the info-line.

3.4.4 Hide [SHIFT]+[BACKSP]

Select this option to hide all non-selected objects in a window from display.
This is particularly useful for large directories to ensure that individual
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marked files are not separated by those of no interest, but are shown all of a
piece one below the other. To restore hidden objects so they become visible
again press the [Esc] key to re-read the directory, or activate Hide once more
(either all or no files must be selected, which is automatically the case after
the first application of the function).

3.4.5 Deselect folders A.

This function deselects all currently selected folders in the topped directory
window. This can be useful when one wants to select a given file with the
autolocator, for instance, but there is unfortunately a folder with the same

name or same starting characters in the same directory. Press [Control] + [Polnt]
and the folder will be deselected.

The five items in the next section of the menu may be used in any desired
combination. When switched on, a tick appears to the left of the menu entry.

3.4.6 Length AL

Where the directory windows are displayed as text, this option additionally
displays the file sizes after the filenames. A repeat selection switches the
length display off again.

If Special > Settings... > General has the Calculate folder size checkbox active
(crossed), the sizes of folders will also be shown; as this may take some time
to calculate with large folders, it is best left switched off unless this
information is required specifically.

3.4.7 Time AZ

Where the directory windows are displayed as text, this option additionally
displays the timestamp the time files were created or last modified. A repeat
selection switches it off again.

3.4.8 Date AD

Where the directory windows are displayed as text, this option additionally
displays the date files were created. A repeat selection switches it off again.
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3.4.9 Attributes AR

Displays the file (and possibly folder) attributes, which have the following
meanings:

a: Archive bit set
r: Read only
h: Hidden

8: System file
A repeat selection switches the attribute display off again.

3.4.10 Access rights AJ

The access right of a file or a folder are divided into three parts: “Owner”,
“Group” and “Others” . The corresponding access rights depend on which
user is currently active and who the file “belongs” to. To make the
identification of the owner possible, it is obviously necessary to have a
corresponding log-in mechanism and a suitable file system. Currently this is
the case only on systems based on MiNTThe actual access rights are then
further subdivided into “readable”, writable and “executable”,

With this menu entry the access rights can be displayed in text-mode
directory windows. The whole thing is shown in the form rwxrwxrwxThe first
three characters represent the rights of the owner, the next three characters
the rights of the group and the last three characters the rights for all other
users. Bits that are not set areidentified by a hyphen ““’ character.

The access rights can be altered in the File Information dialog or via the Context
menu.

3.4.11 Automatic adaptation AS

If this menu option is active (ticked) windows are automatically sized to suit
their contents. Thus the desktop will not be covered unnecessarily by large
white empty areas of directory windows which conceal other windows and
the desktop. Nor will directories be opened as mini-windows where you can
only see a couple of entries of, say, the five files present.

The factors taken into consideration are configured in Speclal > Settings... >
Window placement.
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3.4.12 Locate intelligently

If this menu option is active (ticked) intelligent location algorithms are used
to position windows on the desktop. The factors taken into consideration are
configured in Speclal > Settings... > Window placement.

All the entries in the next portion of the menu have a tick in front of them
when active, and with the exception of Backwards they are alternatives
(selecting one deactivates the current setting). Any folders are always shown
before files.

3.4.13 Single column

Where text display in directory windows is active, and the directory
window is big enough, this option toggles between single- and multi-column
display.

3.4.14 Unsorted MM

This menu entry displays any folders followed by files in directory windows
sorted in the “physical”’ order they were copied to that directory (though in
this and the following five menu entries any folders are always shown before
the files). This command is especially useful for checking the actual
running order of filesin the AUTO folder.

3.4.15 By name A2

Displays any folders followed by files in directory windows sorted in
alphabetical order by name.

3.4.16 By type A3

Displays any folders followed by files in directory windows sorted by
filetype,i.e. by folder/file extender.

3.4.17 By length 74
If the Calculate folder size checkbox is active in Speclal > Settings... > General, this
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menu option displays any folders, followed by files, in a directory window
sorted by their size, so that the longest folder and file appears at the end of
their part of the list. When this checkbox is not active, the folders will

appear sorted in alphabetical order, followed by the files in size order.

3.4.18 By date A5

Displays any folders followed by files in directory windows sorted by file
date. The most recently created files are displayed at the start of the list. Files
with the same date are additionally sorted by time.

3.4.19 Backwards 76

When active (ticked) this menu option reverses the order folders followed by
files are displayed in directory windows when sorted by any of the above
criteria. This option is useful, for example, to display files By date in reverse
order so the oldest files appear at the start of the directory listing.

3.5 The Window menu

3.5.1Close AU
Closes the topped window.

3.5.2 Close all [SHIFT]AU

Closes all windows.

3.5.3 Cycle windows AW

This menu entry is useful to top windows in the background, especially if
the window is completely obscured and cannot be directly clicked on.
Repeated selection tops (brings to the foreground) each window in turn.
Additionally holding down the [Shift] key reverses the order in which
windows are topped.

The Include AV client windows when cycling option in the Speclal > Settings... > Window
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dialog determines whether windows of other AV-aware applications are
included when cycling windows.

3.5.4 Duplicate [SHIFT]AD

Creates and displays a copy of the top window, so both windows display the
same directory.

3.9.5 Adapt
The size of the top window is adjusted to display its contents.

3.5.6 Pin...

The Pin window dialog appears offering a selection of options which can be
used to “pin” the window display irrespective of the global window settings.
The settings for each fixed window are saved to a JINNEE.PIN file stored in
the corresponding window directory, meaning that as soon as you return to
the path the window will open with exactly the same settings.

The following options are available:

- Show: The settings of the menu
entries As Icons, Length, Time, Date, X %2:‘: tion
Attributes and Single column will be | a Adapt
saved. | Sort
|| Mask
~ Position: Window position and | | Autolocator
scrolling will be saved. Ly JEHT Tont
L] lcon font

- Adapt: The setting of Automatic

adaptation will be saved. E

- Sort: The set sort order will be saved.

- Mask: The currently displayed mask will be saved.

- Autolocator: Autolocator input will be saved.

- Text font: The font for the text mode display will be saved.
- lcon font: The font for the icon mode display will be saved.

If there is already an assignment for the current path that is no longer
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wanted, it can be removed with the Delete button.

This dialog can also be displayed by clicking on the “Pin” icon in the
window info-line, where displayed. Refer to 4.16 Speclal > Settings... > Info-line for
more details.

3.5.7 Folders size [SHIFTIAG

Establishes the space occupied by each folder displayed in the current
directory window. This happens in parallel in a thread, i.e. while the sizes
are being established you can continue working normally in jinnee. To use
this function, the system must support MiNT threads.

This menu entry is inactive (greyed out) if Length is not switched on in the
Show menu.

3.6 The Special menu

3.6.1 Context help... [HELP]

Selecting this menu entry or pressing the [Help] key displays ST-Guide loaded
with the appropriate help page referring to what you were doing when you

pressed the [Help] key this is called “context sensitive help”

For context sensitive help to function correctly ST-Guide must be installed
and the file JINNEEHYP must reside in the default ST-Guide hypertext
folder usually a folder called GUIDES located on the root directory of the
boot partition, though other locations can be specified for it in the “PATHS="
entry of ST-GUIDE.INF.

3.6.2 Settings... AE

This menu entry displays the Settings dialog which can be used to configure
almost every aspect of jinnee.

With a little experimentation you should be able to configure jinnee to suit
your requirements. Options are grouped together to make them easier to
find but don’t give up if you can’t find a particular setting immediately it’s
probably in there somewhere!
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The left hand side of the dialog features a scrolling list in which you can
select a function group that you would like to configure. Clicking on an item
in the list brings up a suitable dialog for the group, where you can make the
desired settings.

Because the Settings dialog box contains individual sub-dialogs, alterations
are handled slightly differently to normal dialogs. Alterations are not only
accepted by exiting the dialog via the OK button (which closes the dialog box,
as usual) but also on switching between sub-dialogs. To undo any changes

you must exit the dialog via the Cancel button without changing between
sub-dialogs.

Select the Accept button to update changes immediately without leaving the
Settings dialog the cursor changes to display a “thumbs up”’g, confirming the
changes have been adopted.

The individual setting and detailed explanations can be found in section 4
jJinnee-configuration.

3.6.3 Applications... AT

This menu entry displays the Installed applications dialog which contains a
list of Installed applications. If a currently installed application is highlighted
when selecting this menu entry then the corresponding entry in the list is
automatically displayed. If an application which is not installed is
highlighted an alert is displayed offering an option to install the
application.

The first five entries have special significance as Standard applications:

1. Text editor (“Editor”): Used to edit text files. If a file is opened while the
[Control] key is held down it will be displayed in the text editor.

2. Flle viewer (“Viewer”): Used to display all files for which there is no installed
application. If a file is opened while the [Alternate] key is held down it will
be displayed in the file viewer.

3. File search program (“Finder’): Normally the MagiC MGSEARCH utility is

installed and can be used to search for files via the Object > Find... menu

option. You should either open a directory window or select a drive
beforehand to tell MGSEARCH where it should look for the file(s),
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otherwise it will only search the first partition i.e. normally C..

4. Disk formatting program (“Formatter”): Normally the MagiC MGFORMAT
utility is installed and can be used to format and erase disks via the Object

> Format... menu option.

5. Resolution changing program (“ChangeRes”): Normally the MagiC CHGRES
program is installed and can be accessed via the Speclal > Change resolution...
menu option.

Furthermore the following settings are available:

- Automatic launching of programs after starting jinnee.

- Key assignment to launch programs using specific key combinations.

- Assignment of file extenders to applications. On starting a file for
which a file extender has been assigned jinnee launches the program
and passes the filename as a parameter to the program.

- Command line assignment. For each installed program a command
line can be assigned and passed to the program every time it is started.

Instatled applicotions

EVEREST . PRE
ISTGUIDE.APP
FINDER_E .PRG
RGFORMAT . PRG
CHGRES . PRG
ISTGUIDE . APP
ANIPLAY.PRG
BBUNDL27.PRG

COC_3D.PRG
COPS.APP
ERAILER.APP
EUEREST.PRG
FIFF1.APP
GERGS®38.APP
IC4PLUS.PRG
ICONNECT . PRG
MAINTRIN.PRG
REGA . PRG
RUNPRLK . TTP

{ open:  [e.htm,e.himi,e.pl,e.shint nitpe_____

|:\CAB2_8\ Parallel

_ AU: Kbshift
Rultiple start:( Pass paremeters | &4 poi\Gy tink
Paremeter passing: __UA_START | New window
. | Autostart
Start path: Rpplicetion HL“P' font

— Command line

= == e e o e o . - — T — — —

Send to running APP Empty without paroms.

Quickstart key: -

= Ea Pass selected objects

Ealtl Tor start-keys release

Show: ——— P

Etl

The other options in the Installed applications dialog follow, starting with three

popup menus:

Multiple start: This popup allows you to determine how jinnee proceeds if a
program is already running. The options are:
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Never: The same program is prevented from starting twice.
Ask: Displays an alert beforestarting the same program twice.

Pass parameters: In the case of a file launched from the desktop being
installed for a program already running, its parameters will be passed to
the running program rather then starting the same program again.

Start: The program can be started as many times as desired.

Parameter passing: This popup determines how parameters are handled if Pass
parameters is the selected Multiple start popup menu option. Parameters can
be passed via:

VA _START or
Drag&Drop.
None switches off parameter passing.

Start path: This popup determines which directory is set on starting this
program. The choice is between the start directory of the:

Application,

First parameter or

Top window.
A series of five checkboxes follow:
Parallel

Active (crossed): Programs are started in parallel, commonly called
multitasking.

Inactive: The installed program is started in Single-mode which may be
required to run some, mostly older, programs such as Signum!2 or STAD.

Should you also wish to restrict the amount of memory used by the
program (some tend to grab all available!) then you have to select
(highlight) the program in the directory window, use Object > Information...
to display the File information dialog and enter a value in its Limit field.

AV: Kbshift

Active (crossed): jinnee evaluates the key modifiers: [Shift], [Control] and
[Alternate] when the installed application is started via the AV-protocol.

Inactive: jinnee does not evaluate the key modifiers.
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Follow link

If this option is active (crossed) all symbolic links before starting the
program are cancelled and the path of the original is used instead. This is
important when starting a program via a symbolic link where its RSC,
INF or other required files are not located in that particular directory
and you don’'t want to create extra links.

New window

Active (crossed): On exiting the program all open directory windows are
updated. This is useful, for example, when using archive tools because the
extracted files are immediately displayed without the need to refresh the
window manually using the [Esc] key.

Inactive: Windows are not updated automatically.
Autostart

Active (crossed): The program is loaded automatically on starting jinnee.
Prop. font

Active (crossed): The application is displayed using a proportional system
font. This option is only selectable if this feature is supported by the
system.

Command line

This editable field is used to pass parameters (variables, place holders etc.)
to the program when started.

For more details refer to the online help file.

Send to running APP

Active (crossed): Use the command line also while sending parameters via
the AV-protocol if the program is already running and the Multiple start:
Pass parameters option is selected.

Empty without params.

Active (crossed): The keyed in command line is only observed if
parameters are also present, for example if files are Drag&Dropped onto
the program icon or text object.

Inactive: An empty command line is passed to the program.
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The next five dialog entries only appear for applications other than the five
“standard” applications listed at the start of this section:

Quickstart key

Displays the keyboard combination which can be used to start the
program. Select the Set key button to enter a Quickstart key combination.
A dialog appears that invites you to enter the desired key/key
combination. The [Shift], [Control] and [Alternate] keys are supported. The

Differentlate ‘Shift’ keys checkbox allows you to make a different assignment
for the left and right [Shift] keys.

A mouse click clears an existing key assignment.
Important!

The Quickstart keys only work if the Speclal > Quick-keys menu option is
active (ticked).

Pass selected objects

Active (crossed): Any selected objects are passed as parameters if a
program is started using a Quickstart key combination.

Wait for start-keys release

Active (crossed). When using a quickstart key, the application is launched
only when the modifier key is released.

Inactive: The application is launched immediately the quickstart key or
combination is pressed.

Open
This editable text field is used to specify which files the program
supports. Double-clicking on any of the specified filetypes from the

desktop will start the program with the selected file passed as a
parameter.

Normally entries consist of file extenders, for example: *GIF*IMG*TIF
etc. but it’s also possible to enter more complex filemasks as desired, i.e. to
also install programs for filenames starting with a given string etc.
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Important!

Do not leave spaces between individual entries and use the comma “”
character as a separator between multiple entries.

If a file extender is installed for more than one application, a popup
appears when a matching file is clicked on from which the desired
application can be selected.

Show

This editable field can be used to specify a program to display given
filetypes. Double-clicking on a file that has the relevant extender from
the desktop with the [Alternate] key held down displays the file in the
installed application instead of the default installed “Viewer” program.

Across the bottom of the dialog is a row of five buttons:

Select this button to install a new program. The file selector appears in
which you can choose the desired file. Alternatively a new program can be
installed by highlighting the file in a desktop directory window or on the
desktop and selecting the Speclal > Applications... menu entry; clicking on Yes
in the confirmation dialog brings up the Installed applications dialog where
you can select the desired options.

Change

The file selector is displayed ready to select a new application to adopt the
current settings.

Delete: The selected application is removed from the list of installed
applications.

OK: The dialog is closed and any changes made are retained.

Cancel: The dialog is closed and any changes made for the currently selected
application are lost.

Installed applications are listed alphabetically beneath the first five default
entries.
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3.6.4 icon manager... [SHIFT]AI

This menu entry is used to select which icons jinnee displays for the various
devices, folders and files and these details are stored in a configuration file

specified in the Speclal > Settings... > Paths dialog Icons editable field, ICONS.INF
by default.

As soon as the menu entry is selected, jicons.prg starts up and three windows
are displayed:

- Entry
-lcons
- Mini-lcons

The Minl-lcons window displays all available mini-<icons which are placed in
front of objects when viewing directory windows in text mode.

The lcons window displays all available icons which are used to display
desktop objects and in windows when viewed in icon mode.

The main Entry window contains a list of all the current icon assignments.

A new list entry can be added by double-clicking on any icon or mini-icon in
any of the three windows, or by selecting the Entry > New entry menu item.

E[ Icon assignment

Drives are assigned as
folders, with the device Wl
“name” being followed by

a colon “” character. Drive 'con type T @ Case sensitivity off (A=a)
_ _ O File i Dpeaed var innt
icons are only displayed on @ Folder Desktop variant
(O Label
the desktop, so naturally & ias tebin -
the Desktop varlant checkbox O Notepad |_1 [ ok ]

must be active (crossed). L

Make sure that the entry does not follow a wildcard entry (“*”, “?”) specific
devices must be listed before the “?.” entry otherwise they will be ignored.

Individual items in the Entrles window can be re-ordered easily with
Dragé&Drop operations. Simply click and drag on any entry to move it to a
new position. If the window border is reached the window contents
automatically scroll in the appropriate direction.
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Icons are assigned to specific files using file masks, which may include wild
cards. To do this double-click on any icon in any window and enter the
desired file mask/sinto the editable field.

Do not leave spaces between individual entries and use the comma |,
character as a separator between multiple entries.

!E[—-——-— -Icnn usslgment e —

The Label entry is intended
for removable media, for I" INNEE. APPL ——— S ————— |
instance. If you specify ~ lcon type ﬁ Case sensitivity off (A=)
here the medium’s name O, File { | | Dpened var innt
then the selected icon will 8 E“;ﬂfr [] Deskiop variant
ape
be used automatically for (O Wastebin
this medium. O Notepad & E

An existing entry can be edited by double-clicking on it, or deleted by
highlighting the line and then using the Entry > Delete menu item or by
pressing the [Delete] or [Backspace] key.

Existing entries can also be duplicated using the Entry > Duplicate menu option,
or by holding the [Shift] key down and dragging any line to a new position.

The icon displayed for an existing entry can be changed by dragging a new
icon from the lcons window onto the relevant line.

If you previously used a desktop which saves its folder and file icons in RSC
file format, you can also use these icons with jinnee by copying the RSC file
to the ICONS folder inside the JINNEE folder.

If you prefer to store your icons elsewhere, select the INF-flle > Locate RSC
directory menu entry and then set the desired path with the file selector.

Jicons offers the following search functions:

Search for icon entry:

Double-click on any icon in one of the icon windows while holding a

modifier key pressed down ([Control], [Alternate] or [Shift]), and jicons will
automatically jump to display the first entry for that icon already selected
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in the Entry window list. If several entries are assigned, repeat the search
action to find further entries.

Search for lcon entry by name:

As text is entered it is displayed in the info-line of the Entry window and
Jicons automatically selects the first icon entry containing the entered
text. Pressing [Tab] moves between all matching entries, where more than
one matching entry exists. Press [Esc] to clear the entered text.

If jicons finds an error in the INF file or in the associated RSC files, then
besides displaying a brief warning alert it writes more details of the cause of

the error to a file. This file will have the same name as the INF file but with
the extender ERR.

The icons may be contained in various RSC files. In the Icons and Mini-icons
windows this is indicated by twin divider lines that include the name of the
file. A double-click on one of the subdivided areas starts the RSC editor
(perhaps Resource Master or Interface) that has been installed in jinnee as
an application for RSC, in which you can edit (alter) the icons.

Note: It is best to leave the supplied RSCs unchanged and to use your own
RSC files to add new icons, or to store any that have been altered. That way
you can ensure that these new icons are not overwritten when the next
jinnee update is installed.

3.6.5 Change resolution...

Providing you are working under MagiC, this menu entry permits you to
change the current screeen resolution. Normally the program CHGRES.PRG
will be started that allows simple ways of choosing between available
resolutions, although it is possible to specify a different program (if

available) in the Special > Applications... dialog.

3.6.6 Kobold AK

If Kobold is installed, this menu entry provides a convenient way to toggle
between Kobold and jinnee’s normal copy operations.
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3.6.7 Backup mode "M

This menu entry offers the option to skip over files in the destination
directory with the same filename and same or newer date-stamp during
copy operations. When active (crossed) only files which have changed are
copied, which can speed backup operations considerably.

Important!

Make sure the system time and date are set correctly before activating this
option!

3.6.8 Quick-keys [SHIFT]AS

This menu entry provides a convenient way to toggle on/off the Quick-key
keyboard shortcuts for launching applications. This is useful if you have
installed applications assigned to single keyboard characters (i.e. used
without a [Shift], [Control] or [Alternate] modifier key) but want to continue usi ng
the Autolocator function.

This menu entry affects both shortcuts assigned to installed applications
and to programs installed in the Speclal > Settings... > Quick-keys dialog.

3.6.9 Load desktop...

This menu entry can be used to load a jinnee configuration file at any time,
using the file selector to locate the relevant file. On loading, the current
desktop configuration is replaced and so all active settings are lost.

3.6.10 Save desktop...

Jinnee saves the current configuration. The file selector is displayed and can
be used to specify the path and name of the configuration file, INNEEINF
by default.

If you regularly work in more than one resolution or colour depth you can
configure jinnee to load different configuration files for each resolution
automatically on starting. This works by saving a configuration file with a
specific filename as follows:

58



The jinnee menus

- x for the horizontal resolution in pixels
-y for the vertical resolution in pixels
- p for the colour depth (number of bitplanes).

On starting, jinnee looks for configuration files in a fixed priority order as
follows:

- A filein the format “xy.Ip”
- Filein the format “xy.INF”
- Filein the format “JINNEE.Ip”
- Filein the format “‘JINNEE.INF”
Here's a few examples:
- 640x400 resolution (ST-high) in two colours (1 bitplane): 640400.I1
- 640x200 resolution (ST"medium) in four colours (2 bitplanes): 640200.12
- 640x480 resolution in 16 colours (4 bitplanes): 640480.14
- 1024x768 resolution in 256 colours (8 bitplanes): 1024768.18
- 800x600 resolution in 32k (TrueColor) colours (16 bitplanes): 800600.116
- 640x480 resolution in 16.7 million colours (24 bitplanes): 640480.124

3.6.11 Notepad... [SHIFT]AN

Displays the Notepad dialog ready to enter a desktop note, which can then be
placed on the desktop. Refer to 2.4 Notepad functions for more details.

3.6.12 Empty wastebin

This menu entry will permanently delete the contents of a recoverable
wastebin that was configured in Special > Settings... > Paths.

3.6.13 GEMScript... AG

Jinnee is an application-independent GEMScript server. Select this menu
entry to begin such a recording. All operations in other applications that are

record-capable will be recorded, and subsequently can be replayed as
desired.

For more information about the GEMScript protocol refer to the Atarl
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GEMSCRIPT-protocol documentation (Freeware).

Jinnee can be controlled in various ways using GEMScript commands (refer
to JIN_GSCR.TXT), but is currently not record-capable.

If youre interested in controlling applications using GEMScript take a look
at Scripter, programmed by Holger Weets, and available from Atari Workshop.

3.7 The Quick menu
This menu isinitially empty until user-configured. The menu may contain:

- A list of programs which can be started directly by selecting the
corresponding menu entry.

- Files or folders that can be opened by selecting their menu entry.

Entries are added to the Quick menu using the Speclal > Settings... > Quick-keys
dialog. Each entry includes a checkbox at far right which, when active

(crossed), includes the object in the Quick menu.
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4 Jinnee configuration

Here follow the details of all the settings for each entry listed in the Special >
Settings... dialog.

With checkboxes, an option is activated by clicking on it, or using the
keyboard shortcut (underlined letter together with [Alternate]) so that it
carries a cross. Where there is no separate description for the inactive
(uncrossed) state, it will be the opposite of the active one.

The round radio buttons allow only one alternative to be selected from the
group. Popups, too, permit only one of the available options to be chosen.

For clarity, the illustrations in the following pages only show the relevant
part of the sub-dialogs that apply to each function, instead of the complete
Speclal>Settings... dialog.

4.1 Settings... > Autolocator

— — — — — — —

% Cursor keys move selection

'Control+Cursor’ stays in same level
I Always select only the first object
E% 'Return’ acts only on first selected object

Rapid keyboard buffer clear

'ESC’ deletes locator and selection
——— ———

Cursor keys move selection

]

Active (crossed): The cursor keys move the selection cursor around
windows highlighting one object at a time as it travels; if more than one
object has been selected then the cursor will move to the object adjacent
to the first one and the remaining objects will be deselected.

Inactive: The cursor keys behave like window scroll arrows and multiple
object selections are retained; to temporarily switch to the opposite
behaviour hold down the [Control] key during scrolling.

‘Control+Cursor’ stays In same level

Active (crossed): In a window that includes popped open folders, jinnee
tries to remain at the same directory level on which the cursor is located.
This only functions for popped open folders and if the Cursor keys move
selection option is active (crossed). The aim is to prevent branching
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deeper into the directory tree if the adjacent item is at a lower level the
cursor will skip over it to the next item at the same level.

Always select the first object

Active (crossed): Only the first object which matches the search string is
selected.

Inactive: All matching objects are selected.
‘Return’ acts only on first selected object

Active (crossed): If more than one object is selected only the first will be
opened.

Inactive: All selected objects will be opened.

Important!

The Object > Open menu entry always opens all selected objects this setting is
ignored.

Rapid keyboard buffer clear

Active (crossed): In most cases this option prevents the “cursor overrun”
problem, which causes the cursor to continue scrolling after letting go of
the key. If setting this option causes unwanted side effects disable it.

Inactive: Standard keyboard buffer behaviour is employed.
‘Esc’ deletes locator and selection

Active (crossed): Pressing the [Esc] key clears the auto-selection and
re-reads thedirectory at the same time.

Inactive: The [Esc] key behaves normally it re-reads the directory while
the auto-selection entry can be cleared with the [Space barl].

<] Background windows remain active

4.2 Settings... > Background
operation

Singte-click in background operations

@® Execute in the background
(O Top window
(O Top window and ewecute

E} Deselect in background
Top window with right mouse button
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This dialog contains all the settings which affect how jinnee handles
background operations:

Background windows remain active

Active (crossed): Background windows react to mouse-clicks in the same
way as in a topped window.

Inactive: Background windows can be operated in the background using
the right mouse button.

Single-click in background operations

One of the following options can be selected to detemine how a single
mouse click on a background window is handled:

Execute in the background

The window remainsin the background, any object clicked on is selected.
Top window

A single click on a background tops the corresponding window, any
object clicked on is not selected.

Top window and execute

A single click on a background tops the corresponding window, any
object clicked on is selected.

Deselect in background

Active (crossed): Clicking on a clear part of a background window
containing any selected object/s deselects everything and then tops the
window.

Inactive: The background window is topped and the object/s remain
selected. A second click in the now topped window deselects everything.

Top window with right mouse button

Active (crossed): A right mouse click anywhere on a background window
tops it. In this case, provided Background windows remain active is switched on
(crossed), a right mouse click is not interpreted in the way selected in

Speclal > Settings... > Mouse clicks (though if this should be off, any right
mouse button actions are carried out in the background).

Inactive: A right mouse click in a background window is interpreted as
whatever has been selected in Speclal > Settings... > Mouse clicks.
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4.3 Settings... > Background: Desktop

You can customise your desktop background with combinations of the
following options:

- Pattern: An image tiled to fill the 'T

attern: [IMG\DESK ING\DESKXz_Xp. IMG_______________ |
desktop. 4'.- Random pattern ["] Scale

- Image: An image can be placed

centrally on the dESktOp. Graphic mode: | SEaclul trnnseurant I

- Colour: A colour from the | Mask: |___ _ - _ |
available palette fills the
desktop.

- FllI: A fill pattern from the fill
popup is applied to the desktop.

Pattern

In this editable field an image, in IMG format, can be selected manually or
with the file selector, which is to fill the entire desktop background. Images
smaller than the screen resolution are “tiled” so they fill the screen.

If you have a selection of background images and would like jinnee to
randomly select between them you must rename the files according to the
following manner:

If you have, say, three tiling patterns for 256-colour resolution (in IMG
format), then rename those three individual files to DESKI1_8.IMG,

DESK2_8.IMG, and DESK3_8IMG and in the Pattern editable field enter the
pathname plus DESK%z_%p.IMG. Here %z is a placeholder for a random
number used for selecting the pattern and %p for the number of bitplanes
the image contains:

- 1bitplane: Mono resolutions (ST-high)

- 2 bitplanes: 4-colour resolutions (ST=-medium)
- 4bitplanes:16-colour resolutions (ST-How)

- 8 bitplanes: 256-colour resolutions

X Random pattern

To inform jinnee how many images it can choose from, enter the number of
images available into this editable field. If you enter a number higher than
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the number of available images, jinnee may randomly select a number for
which no pattern image is available, in which case a plain white desktop is
displayed.

Scale
Thisoption is only selectable if NVDI v5 or later is installed.

Active (crossed): The desktop background image will be scaled to fill the
screen.

Inactive: The image isdisplayed at its original size without scaling.

In this editable field you can select manually, or via the file selector, an
additional desktop image in IMG format that will be displayed centred

over any tiled Pattern.
Graphic mode

This popup controls how the two sets of pixels from the centred image and
the Pattern background interact with each other. A number of alternatives
are offered of logical ways to combine the individual pixels of the source
"S” (the centred image) and its mapping onto those of the tiled pattern
background destination “D”.

The exact appearance of the combined image depends on the selection
made in the popup (“Y” represents “not”):

-  White

- SandD

- Sand ID

- Opaque

- ISand D

- Invisible

- SxorD

- Transparent

- (SorD)

- S xor D)

- Invert

- SorlD
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- Inverse

- Inverse transp.
- (S and D)

- Black

The effects of the various combinations are difficult to describe just try
them out for yourself!

Mask

In this editable field a monochrome image, in IMG format, can be selected
manually, or via the file selector, for use as a mask for the centred image.
If a monochrome IMG format Mask image and the centred desktop Image
have both been loaded, the desktop image will be masked by the mask
image: For each pixel set in the mask the background is removed (other
areas of theimage remain intact) and the desktop image is drawn over it.

Normally when using a mask you should choose Speclal transparent for the
Graphic mode, which makes jinnee automatically use the correct mode to
lay the picture transparently over the masked-out area with both palette
and Hi/TrueColor pictures.

If you prefer a simple colour and/or patterned desktop, or you need to save
memory, the Colour and Fill popups can be used to configure an attractive
desktop background. The choice is yours. The number of colours that the
popup makes available naturally depends on the current screen resolution:
with monochrome there is only black or white.

4.4 Settings... > Background: Windows

Directory windows can be — —_—

. ]
underlaid with a Pattern Pattern: |IMG\WINDIRG\MINDXZ_%p . ING_ — |
(optionally a randomly selected 4- Rondon pattern
image), background Colour or Fill (] pattern in tent node |

pattern. Be careful to select a
combination which leaves the
filenames readable! Refer to
Pattern 1n 4.3 Speclal > Settings... > Cotour: [__]
Background: Desktop for more '
details.
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Pattern in text mode

Active (crossed). Text and icon windows display a background Pattern
image.

Inactive: Icon windows display a background Pattern image, text windows
display a background dependent upon the settings in the Colour and Fill

popups.

E Show selected text in colour
Show meonochrome icons in colour
4.5 Settings... > Colours | Fites: |
Fold :
The settings available in thisdialog I pr:gr:: : =
are only useful in colour screen Hidden: [N
resolutions. | |
Show selected text In colour ———— I=
Active (crossed): When coloured | [ ——| N
text objects are selected they — |
retain that colour in their

selected state.

Inactive: Selected text objects are
displayed as white text on a black
background.

Show monochrome icons In colour

Active (crossed): Monochrome icons are displayed using the current text
colour.

Inactive: The icons are displayed in black and white.

Specific colours can be assigned to display Flles, Folder, Programs and Hidden
objects in their respective windows and popups, which makes it easy to spot
executable programs, folders and hidden objects.

Furthermore there are fourteen additional slots which each include an
editable file mask field where colours can be assigned to specific objects as
desired.
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4.6 Settings... > Copying o o
: . : — Dlalog for - =
Thisdialog includes all the Copy ::: :::':"_::""ET:':;Q on error
settings which control jinnee’s Move -
internal file operations. E%f::: tink 5 Detete uith "Detete’ Key
The Dialog for frame contains the Create Links wlth *Alternate’
following options which, when gopglny l: 1hrB:dS“i‘>'ﬂ:91C 5-13:I » -
. . ackKgroun s euvao reaag co actuive ac on
active (crossed) display the Earnglf resgurce fork lost ¥ ’
jinnee cow dialog before Beep If resource fork lost

starting the following

Mlove instead of copy within device

IT object/s already present: Ask

OperatlonS: Defaultl dialog on cnnl’lict:[ Cancel |

Move
Create link
Delete

COPV Copy buffer limit: q, ______ bytes (8=none) —]

Show Indicator

Active (crossed): If one or more of the individual checkboxes in the Dialog
for frame at the top of this dialog are inactive, this option automatically
displays a progress dialog during all file operations which is identical to
the Copying dialog except there are no buttons to select.

Inactive: The progress dialog is displayed only for the functions set in the
Dialog for checkboxes.

Overview dialog on error

Active (crossed): If an error occurs during a file operation a dialog
offering further information to help track down the problem is

displayed. This dialog can be closed using the [Return] / [Enter] keys or the
Closer icon.

Inactive: No error dialog is displayed.

Delete with ‘Delete’ key
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Create links with ‘Alternate’

Active (crossed): Symbolic links are created if the [Alternate] key is held
down during copying operations. The downside is you lose the ability to
rename files on-the-fly.

Inactive: Links can be created by holding down the [Alternate] + [Shift] or
[Control] + [Shift] key combinations. Files can be renamed on-the-fly.

Copying in threads (>=MagIC 5.13)

Active (crossed): Copy operations are started in parallel.

Important! This feature only works properly with MagiC versions since
0.13. Earlier versions should not use this option either upgrade or disable
this option.

Inactive: Normal copy operations are used.
Background pseudo thread copy active (Mac only)

Active (crossed): On Macintoshes, jinnee uses its own internal routines
which perform file operations in parallel just like threads. These routines
also currently have minor limitations:

Under MagiC Mac and working with real Mac files, these routines
attempt to copy the resource fork along with the file itself but the MagiC
Mac file system sometimes prevents this. For example folders and links
sometimes lose their icons.

Inactive: Normal copy operations are used.

Warn If resource fork lost

Active (crossed): If jinnee attempts to copy a resource fork and encounters
an error (because the destination file system does not support resource
forks) an alert is displayed.

Inactive: No warning is displayed if jinnee encounters an error
attempting to copy a resource fork.

Beep If resource fork lost

Active (crossed): If jinnee attempts to copy a resource fork and encounters
an error (because the destination file system does not support resource
forks) a warning “ping” is sounded.

Inactive: No warning “ping” is sounded if jinnee encounters an error
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attempting to copy a resource fork.

Move Instead of copy within device

Active (crossed): Files dragged within a device (drive) are moved instead
of copied.

Inactive: Files are copied normally.

If object/s already present

If existing objects are encountered during copy operations jinee responds
according to the selection from this popup menu, which offers the
following options:

Ask: A conflict dialog opens where you can make further choices as
described below.

Skip: Conflicting file/s are not copied.

Replace: Overwrites existing file/s with the copy without further
queries.

Default button on conflict

If existing objects are encountered during copy operations and Ask is
selected in the If object/s already present popup, jinee displays a file conflict
dialog which includes options to resolve the conflict.

The default button, which can be selected via the [Return] / [Enter] keys, can
be chosen in this popup, which offers the following options:

Rename: Be sure to enter the new name in the editable field before
activating this!

Cancel: Breaks oif the copy operation.
Skip: Does not copy the conflicting file.
Skip all: Does not copy any conflicting files, without further queries.

Replace: Overwrites the existing file with the copy having the same
name.

Replace all: Replaces all existing files with conflicting names without
further queries.

Copy buffer limit
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operations, there is still memory available for other programs.

Enter “0” for no limit, in which case jinnee can use all available free
memory.

Setting a limit is particularly desirable where background DMA (Direct
Memory Access) is not active because programs are frozen during disk
access. With large files, even with parallel processing using Copying In

threads active, your work flow may well be disrupted. Setting a limit for
the copy buffer forces jinnee to copy large files in smaller chunks, which
means programs are not frozen out.

Select a copy buffer limit which is divisible by 1024. For example 16384
(16KDb), 32768 (32Kb), 65536 (64Kb) and so on.

4.7 Settings... > Date

Truncated weekdays before date T S
Active (crossed): When <] Truncated weekdays before date
viewing text windows ~ Within the last week
with the Show > Date > Intelligent date/time display
option active (ticked), the @ with weekdays
day of the week is O with days passed

] with time

displayed before the file
date, abbreviated to two |
characters (Mo, Tu, We, Th, . . —
Fr, Sa, Su).
Inactive: The date is displayed normally.
Within the last week

For objects which have been changed in the last week extra options are
available if Intelligent date/time display is active (crossed):

with weekdays:
The following strings are used:

- Today

- Yesterday
- Tomorrow
- Monday

/1



jinnee configuration

- Tuesday

- Wednesday
- Thursday

- Friday

- Saturday

- Sunday

with days passed:
The number of days since the object was last changed is displayed.
with time:

The time the file was created/last modified is displayed following the
day even if the Show > Time menu option is inactive (unticked).

4.8 Settings... > Desktop l—' —
Double left: | |cons I : |
Single right: [ orives J[_ 1|

d1ffe1:en1: mouse + keyl?oard Double right: mppswitch [ ]|
combinations on the jinnee Ctr L+doubtlec ! ick: object | |

desktop. Note that you can Alt+doublec!ick: “CPHs | I |

assign more general mouse \
clicking actions in Special > > Top jinnee If desktop clicked
Settings... > Mouse clicks that apply | &I 1cons snep mode: [ icon base ]

not just on the desktop but Horizontal: 16| Uertical: 16 ]

everywhere. But the desktop offers some further options which may be set in
thisdialog.

Actions can be assigned to five

Each mouse + keyboard combination includes a popup menu offering the
following entries for actions to be performed when they are used:

Nothing
No special action is assigned to this.

Context
Calls up the context menu.

icons
A popup isdisplayed with entries for each icon installed on the desktop.

Drives
A popup isdisplayed listing all available drives.
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AppSwitch
A popup 1is displayed listing all running applications, allowing you to
switch to a different running program.

CPXs
A popup is displayed showing all active control panel CPXs.

FolderPop

The contents of a given folder will be displayed as a popup. The desired
folder has to be specified via the file selector that appears when the empty
box to the right of this popup is clicked on. To remove an entry without
choosing another, enter a space in the filename field.

Object
Select this entry to assign the mouse + keyboard combination to an object.
To assign the object click on the empty box to the right of the popup menu
and select the desired object using the file selector. To remove an assigned
entry altogether, enter a space in the filename field.

When the mouse-clicks for the Icons and Drives options are used on the
desktop, they display popup menus which include arrow characters that can
be followed to display further sub-popup menus and navigate the entire file
system. Drives and directories are displayed in bold characters with
individual objects displayed in normal text.

Selecting a drive or directory entry opens a jinnee desktop window to
display its contents. Programs and other executable objects can be launched
by simply selecting their entry. Selecting a file for which an application is
installed prompts jinnee to run the installed application to open the file. If
no application or viewer is installed jinnee displays the file in the default
file viewer.

Top Jinnee If desktop clicked

Active (crossed): A left mouse-click anywhere on the jinnee desktop will
make jinnee the active or “topped” application. The jinnee menu bar will
be displayed and any open directory windows will be displayed in the
foreground.

Inactive: Single mouse clicks on the jinnee background are ignored.

icons snap mode
Active (crossed): Icons are snapped onto a pre-defined Horizontal and Vertical
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grid defined in pixels. If the Horizontal and Vertical settings are both set to
“1” this option has no effect.

Inactive: Icons can be freely positioned on the desktop.

The positioning of icons relative to the grid can be selected from the popup
menu which offers the following options for reference points:

- Corner of the screen

- Centre of the screen

- lcon corner of nearest icon

- lcon centre of nearest icon

- lcon base of nearest icon

4.9 Settings... > Dragging
Drag Icons In real-time rE Drag Icons in real-time
Drag text In real-time L} Trensparent
Active (crossed): During ~ Rutoscrolling while dragging 1
Drag&Drop actionsiconsare flan. mouse movement while scrolling: ﬁr pinel
moved in real-time with the Time before scrolling sterts: 288 ns
CUrsor. Ulir tual scrolling: 32 piwnel
Scroll factor: 1

Inactive: An outline of the icon

1s moved instead. Owners of r Spring folder [X with real windows
slower machines may find J Keep destination window open
o o . flax. . 1- plnetl
real-time display jerky or GH. ROUSS Revenent: 1- plue
Folders spring open after (8=never): S80_ ns
unacceptably slow.

Drag text In real-time

Active (crossed): During Drag&Drop actions text is moved in real-time
with the cursor. The Transparent option offers a choice beween solid or
transparent text display during dragging, if the operating system
permits this.

Inactive: An outline of the text is moved instead. Owners of slower
machines may find real-time display jerky or unacceptably slow.

Autoscrolling while dragging
During Drag&Drop actions jinnee directory windows auto-scroll as the

4



jinnee configuration

mouse cursor hits the window border to display hidden areas of the
window. The following options offer precise control over auto-scrolling:

- Max. mouse movement while scrolling: x pixel determines how far the mouse
may be moved before scrolling becomes active. With very fast
movements scrolling will not take place.

~ Time before scrolling starts: x ms sets the scrolling delay after the window
border is reached.

- Virtual scrolling: x pixels sets the border around the working part of a
window within which scrolling is to be activated.

- Scroll factor is the factor by which the scrolling speed is to be accelerated.

Spring folder with real windows
Active (crossed): Spring-folder behaviour is active.

Inactive: Popups open in place of real windows, which also allow you to
reach a drag destination at a lower directory level.

Keep destination window open

Active (crossed): The last-used spring window is left open after a drag
action.

Inactive: Windows behave normally.
Max. mouse movement x pixel

Sets how many pixels the mouse may be moved before dragging becomes
active. On fast movement a folder will not be opened.

Folders spring open after x ms

The time in milliseconds before a folder (or drive) under the mouse cursor

springs opens can be set here. If “0” is entered folders do not automatically
spring open but, when selected, can still be opened by pressing a
user-definable key.
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4.10 Settings... > Drives

Always show new drives 5 Aluays show news dr ives

Use stonderd icon positions
Use label as Icon title

Active (crossed): New devices Get Tabel at Initlalisation

(drive partitions) installed on the
system will be automatically Never dlsplow: — o
mounted and appear on the No 'Dfree’: I

dESktOp. No lcon letters: ________ S ——— _—
No lebel: AB e —

Always display: | e e e e e

Inactive: New devices do not
appear on the desktop

. | | "Smart update’ of disk space
automatlcally. Evceptions: RB

tject on shutdown: ___ __ oo

Use standard Icon positions

Active (crossed): jinnee remembers the position of the device icons, the
wastebin and notepad.

Inactive: jinnee automatically determines a sensible place to position new
device icons.

Use label as Icon title

Active (crossed): If the system can ascertain the drive label it is used for
theicon title.

Inactive: The title of the device is set via the Object > Information... dialog.
Get label at initialisation

Active (crossed): jinnee ascertains the individual drive labels on starting
or when using the Object > Find drives menu entry.

There follow six editable fields in which you can enter drive letters,
normally without separators (such as spaces or commas):

Always display:

The letters for drives which should always appear on the desktop can be
entered, even when the devices are not available, such as CD-ROMs and
removable media.

Never display:

The letters for drives that are to be suppressed so they never appear on the
desktop can be entered here.

/6



jinnee configuration

No ‘Dfree’

The free space is not ascertained for any drives entered here. (For
example the MagiC virtual drive U).

No Icon letters

No drive letter will be displayed for any device entered here. For example,
if you have a particularly nice icon for a ZIP drive you may prefer that the
display not be spoilt by an unsightly drive letter.

No label

No label will be ascertained for any devices entered here, for example
floppy drive A:

Eject on shutdown

Removable media devices entered here are ejected on shutdown. This
includes, for example, ZIP and SyQuest drives, and the floppy disk when
using jinnee on a Mac under MagiC Mac.

‘Smart update’ of disk space

Active (crossed): The free disk space of all shared pseudo-drives is
calculated at the same time when any changes are made to the files on
them. Pseudo-drives are used with some emulators (such as MagiC Mac,
say) where there may be folders representing Atari drive partitions on a
common higher-level device of the parent system. Under MagiC Mac you
can create several GEMDOS drives as folders on the same Mac volume, for
instance.

Inactive: There is no attempt made to obtain the free disk space on shared
pseudo-drives.

Exceptions

For smart updating the system has to obtain information about all
installed drives at intervals, which can lead to problems such as awkward
delays or warning messages if no medium is present in an
interchangeable device such as a floppy drive. Entering such problematic
drives which are never a part of a shared physical drive in the editable
field stops them from being included in smart updating.
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4.11 Settings... > Flle lengths 5
Show In Kb/Mb D

Active (crossed): File lengthsin
text-mode directory windows are

Show in Kb/Mb
Show only in Kb

Number representation

displayed in Kilobytes and Megabytes O 1.800,8
(to one decimal place, as long as Omit @® 1,000.0
decimals is not active) with a Kb or Mb (O 1000,0
suffix. For example, a file 1087374 ( 108088.0

byteslong would be shown as 1.0 Mb
(or 1,0 Mb, depending on the Number
representation chosen see below).

L | Omit decimals

Inactive: File lengths are displayed normally, with their full lengths in
bytes.

The “Information” dialogs are not affected by this setting.

Show only In Kb

Active (crossed): All file lengths in directory windows are displayed in
Kb (to one decimal place as long as Omit decimals is not active), even if they
are larger than 1 Mb. For example, a file 1087374 bytes long would be
shown as 1061.9 Kb (or 1061,9 Kb).

Again, the “Information” dialogs are not affected by this setting.
Number representation

The radio-buttons in this frame permits adapting the way that numerical
values are displayed. Some countries (much of central Europe and some

others) use a decimal comma where the English-speaking countries use a
decimal point.

This setting effects the file lengths displayed in directory windows as
well asin the “Information” dialogs.

For clarity one can also choose to have a separator after thousands (and
millions) in directory windows, which will be the opposite to the decimal
marker (the “Information” dialogs always use the chosen separator but it
cannot be switched off in them).

Omit decimals
Active: All file lengths shown in Kb or Mb are rounded down to the
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next-lowest kilobyte or megabyte. For example, a file 1061.9 Kb long
would be shown as 1061 Kb, or, if Show In Kb/Mb is active, as 1 MB.

Inactive: Tenths of kilobytes (or megabytes) after a decimal point/comma
are displayed.

4.12 setﬂngs"' > F"ter < Fliter ective ] Show hidden fles

Here object filters can be specified |[j\eepin JinThoD » -

which determine whether objects FINDER.OAT___________ I
are displayed in directory L A— ! _
windows or not. —— m— — -

Fliter active I — —- ——

Active (crossed): The filter is = =

active, so that objects matching |\ —17¢—— ——
the masksentered belowinthe ([ ____________—— " — '
ten editable fields will not be - .
displayed. This can be useful to hide files like FINDER.DAT which is
automatically added to floppy disks by the Mac-OS running MagiC Mac.
This makes it easier to count and de/select objects without having to
worry about irrelevant objects.

Inactive: The filter is not active, all objects are displayed.
Show hidden files

Active (crossed): All objects, or all unfiltered objects when Filter active is
switched on, are displayed.

Inactive: No objects which have their hidden attribute set are displayed.

4.13 Settings... > Fonts

This dialog is used to configure which fonts are used within jinnee for
various purposes. Clicking on any of the boxes brings up the font selector
where you can select the style and size from from a list of the fonts installed
on the system, both proportional and non-proportional. The following
options are available:
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Desktop Icons: — ——I

The font used for the icon text
Yindow Icons: |Monaco Mono gpt

labels on the dESktOp' Vindow text: |Monaco Mono 18pt

Window Icons: el T—]
The font used for the icon vopups: [Ronaco Rone Ll
text labelsin directory BubbleGER:
windows. Please note the Lonsole: |Monaco Mono 18pt |
icon spacing is font

dependent so the smaller the

font the closer adjacent icons appear and as a consequence more icons can
be displayed in any given window size. However, too close a spacing may
make “rubber band” selection of multiple files difficult.

Window text:

The font used for the text-mode entries in directory windows. Please note
the object spacing is font dependent so the smaller the font the closer
adjacent entries appear and as a consequence more objects can be
displayed in any given window size. However, too close a spacing may
make rubber band selection of multiple files difficult.

Info-line

The font used to display the information line across the top of each
directory window.

Popups

The font used by jinnee to display its popup desktop navigation menus.

BubbleGEM

The font used by the BubbleGEM utility (BUBBLE.APP) to display help
bubbles. Proportional fonts only work with BubbleGEM Release 4 and
higher. This does not affect the single-line help text dispayed at the

bottom of dialog boxes, which will always be in the system font as used in
thedialogsetec.

Console
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4.14 Settings... > General
—
Grow/Shrink boxes Grow/Shr ink boxes \
_ _ Open dialogs at mouse
Active (crossed): Grow/Shrink Recall dialog positions
boxes. which look like . Beep if accessing invalid drives
’ Folders stay selected on closing
growing ghost images of | Take numbers into account when sorting
: . Upen TTP dialog box in DragGDrop operations
wmdows, arc dlsplayed when INGs special adaption (PowerBook 198 only)
opening/closing objects. BubbleGEM help tent underneath dialog box
Show signal for switchable menu itens
Inactive: No Grow/Shrink Ef:ﬁ"l“? 't'ﬂlﬂﬂr size
boxes are displayed. Shwa_:_eﬂ .c,;*:'?;mas
Open dialogs at mouse T

Active (crossed): Dialog boxes are opened at the current mouse position,
which is especially useful when using large screen monitors.

Inactive: Dialogs are displayed centrally, unless other options apply.
Recall dialog positions

Active (crossed). Every dialog is opened at its previously displayed
position.

Inactive: Dialogs are displayed centrally, unless other options apply.
Beep If accessing Invalid drives

Active (crossed): The system ping is sounded on attempting to open an
invalid device.

Inactive: An alert is displayed on attempting to open an invalid device.
Folders stay selected on closing

Active (crossed): On closing a folder to display its parent directory the
folder remains highlighted, making it easy to locate without resorting to
scroll bars or the Autolocator.

Inactive: No folder is highlighted on closing a folder.
Take numbers Into account when sorting

Active (crossed): Digits in filenames are handled as numbers. For example,
when sorting a series of image files IMAGE10 will be listed after IMAGES
instead of after IMAGE1l and before IMAGE2. Many programs do not
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handledigitsin filenames correctly or predictably.

Inactive: Digits are handled as characters, so that the sort order of the
above example would be IMAGE], IMAGE10, IMAGE2,..IMAGE 9.

Open TTP dialog box in Drag&Drop operations

Active (crossed): The command line entry dialog is displayed during
Drag&Drop operations ideal for entering different parameters each time
a TTP program is started.

Inactive: TTP programs are started without displaying the command line
entry dialog.

IMGs special adaption

Active (crossed). Any 16-colour images will be converted even if the
screen is displaying only 16 colours (or grey levels) which, depending on
the IMG, may look better. This option is of particular interest on Mac
Powerbook 190 and some Duo models.

Inactive: IMGs are handled normally.

BubbleGEM help text underneath dialog box

Active (crossed): One line of the BubbleGEM help text is displayed across
the lower edge of each dialog, provided BUBBLE.ACC or similar has been
installed on the system. The text changes to show help for the option on
which the mouse pointer rests mainly to indicate which elements have

help texts available. Text longer than the dialog width is truncated use a
right-click to bring up a BubbleGEM bubble instead!

Inactive: No help text is displayed underneath the dialog box, but a
right-click still brings up the bubbles.

Show signal for switchable menu Items

Active (crossed): When toggling the Kobold, Backup mode and Quick-keys
options in the Speclal drop down menu using their keyboard shortcuts, a
confirmation status message is displayed centrally on screen
momentarily. Other keyboard shortcuts do not provide visual feedback.

Inactive: No visual feedback is displayed.
Calculate folder slze

Active (crossed): When opening directory windows jinnee calculates the
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size of folders automatically in the background, so that you do not have to

trigger this manually via the Window > Folder size menu entry. This button
should be deactivated if it causes a noticeable slowdown of the system.

Dither pictures

Active (crossed): From NVDI 5 onwards background images are dithered
if necessary to fit the current colour palette.

Inactive: Images will be displayed with similar colours. Again this only
works from NVDI 5 onwards. Otherwise the image palette has to match
the system palette (JINNEE.PAL) in use.

Show real CPX names

Active (crossed): The full, real CPX names will be shown when the CPX
directory is displayed in text mode.

Inactive: The filenames plus extender will be displayed.

4.15 Settings... > Icons

Delete superfluous bitplanes

Delete superfluous bitplanes D] System uses 256 colour icons in TrueColor
Optimise icons for 16 greyscale resolutions

Active (crossed): On loading icons vertical spacing: 4| pinel
only theicon information for the Hor izontal spacing: 4. pinel
current screen depth is loaded,

- jcon text banner

WhICh Saves memorY- Oversize: ARbove 2_. 3_ Left

System uses 256 colour icons In TrueColor delow 1. 2 Rignt
Active (CI‘OSSEd): If you work in E EI:: T:::'::Ht Banner colour: D
TrueColor or HiColor screen l_h : —_I

depths (more than 8 bitplanes) activate this option to enable the system to
use the 256 colour icons.

Inactive: At best, icons will not be displayed correctly, at worst the
desktop will be unusable.

Optimise icons for 16 greyscale resolutions

Active (crossed): Icons are optimised for display in 16 greyscale
resolutions which is useful for Apple Powerbook/Duo and a few other
users.

Inactive: Icons are displayed normally.
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The horizontal and vertical spacing between icons in directory windows can be

set using the Vertical spacing and Horlzontal spacing editable fields. Note that
too close a spacing may make “rubber band” selection of multiple files
difficult.

The Icon text banner is the underlying banner/box over which the icon text is
laid. You can choose how thisis to be displayed:

Oversize:

Extra pixels can be added Above, Left, Below and to the Right to enlarge the
icon text banner around the text.

Frame banners
Active (crossed): Frames are drawn around each icon text banner.
Inactive: Icons are displayed normally.

Black icon text

Active (crossed): Icon text is displayed in black irrespective of the colours
assigned to the icons in Speclal > Settings... > Colours.

Banner colour

A popup menu is used to set the icon text banner colour. Note the crossed
white box which selects transparent icon text banners.

4.16 Settings... > Info-line

Info-line | — Info-Lline -
This dialog includes all the % infa-tewt Tn 30 (uith orey background onty)
settings which affect the Short info-tent i
display of the window

info-line the line immediately - Puttons visible

Closer
beneath the window title bar. E Pin

lcon/Texnt mode
Optimise window size

Info-line background grey

—d

Active (crossed): The window —
info-line is displayed with a grey background field. This only works with
screen resolutions of 16 colours or more.
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Inactive: The window info-line is displayed with a white background.
info-text in 3D (with grey background only)

Active (crossed): Window info-line text is displayed in 3D, if the Info-line
background grey option is active as well. This too only works with screen
resolutions of 16 colours or more.

Inactive: Window info-line text is displayed normally.

Short Info-text

Active (crossed): Replaces “xxx bytes in yyy objects. zzz bytes free.” with
“xxx /vyyy /zzzfree.

Inactive: Shows “xxx bytes in yyy objects. zzz bytes free.”.
Buttons visible
The following icons can optionally be displayed in the info-bar:

- Closer

- Pin (see 3.5.6 PIn... for more details)
- lcon/text mode

- Optimise window size

4.17 Settings... > Kobold .

Kobold users can use this dialog to | [ Kobold active
control how Kobold behaves. To do this g ;zﬂﬂ
Kobold must be correctly entered in Delete
the Speclal > Settings... > Paths dialog. [J With tong filenames

|| Kobold can copy links |
Kobold can be configured to take over | | 0n cese-protecting drives

| On case-sensitive drives
Copy, Move and Delete operations by
activating the relevant checkboxes.

on )l__ ob jects or more

No Kobold on: U__ — R -

Furthermore, there’s a On x objects or more option to specify a dividing line
below which Kobold will not be used. Kobold is generally most beneficial
for bulk file operations.

It should be noted that jinnee attempts to execute Move operations at one go.
With modern systems, this usually works when files are moved within the
same physical drive or partition by simply amending the directories. If you
have an early version of Kobold (<2.5) it may be much quicker to use jinnee
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and it’s worth considering turning Kobold off for Move operations. With
Copy and Delete, on the other hand, Kobold’s speed can not be beaten. Kobold
from v25 onwards uses a similar procedure and so there is little point
turning Move off with the later versions.

With long filenames
Active (crossed): Kobold is used to handle long filenames.

Inactive: Long filenames are handled by jinnee’s internal routines. Please
note older Kobold versions (before v3.5) do not support long filenames.

Kobold can copy links
Active (crossed): Kobold is used to copy symbolic links.
Inactive: Symbolic links are handled by jinnee’s internal routines.
important!
Kobold only supports symbolic links from Kobold v3.5.

If multiple objects are selected which include long filenames or symbolic
links and Kobold has been disabled for these filetypes, Kobold is used to
copy the other files before automatically handing over to jinnee’s internal
routines to complete the operation.

On case-protecting drives

Active (crossed): Kobold is used to copy files on case-protecting devices
which support upper and lower case filenames but do not differentiate
between them. For example VFAT, Mac-HFS and so on.

Inactive: Internal jinnee routines are used to copy files on case-protecting
drives.

On case-sensitive drives

Active (crossed): Kobold is used to copy files on case-sensitive devices

which support upper and lower case filenames and differentiate between
them.

Inactive: Internal jinnee routines are used to copy files on case-sensitive
devices.

No Kobold on x

Drive letters can be entered into the editable field and Kobold will not be
used on these devices. Kobold cannot copy to the MagiC virtual drive U: so
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MagiC users should at least enter “U” here.
4.18 Settings... > Links

Follow links ———

Thisdialog includes all the
settings which affect how
symbolic links are handled by
jinnee,

X] When starting prograns

When determining filetypes
When passing parameters

When opening folders
> When determining attributes

When starting programs

Active (crossed): The original program, not the alias, is started. This offers
the advantage that files associated with the program (such as RSCs and
INF's etc.) can be found without requiring their own symbolic links.

Individual applications can also be configured via the Speclal >
Applications... dialog.

Inactive: The alias is started.

When determining flletypes

Active (crossed): For filenames linked to programs the file extender
(PRG/APP etc) can be omitted and the file will still be recognised as an
executable program.

When passing parameters

Active (crossed): The original file is passed as a parameter instead of the
symbolic link.

Inactive: The symbolic link is passed as a parameter.
When opening folders
Agctive (crossed): Opening a folder link branches to the original folder.

When determining attributes

Active (crossed): The attributes of the original file instead of the link are
displayed.

Inactive: The attributes of the link are displayed.
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4.19 Settings... > Mouse clicks

Actions can be assigned to six different mouse + keyboard combinations, no
matter where the mouse cursor is positioned in jinnee. Note that in the Special
> Settings... > Desktop dialog you can configure separately what is to happen
with various types of clicks on the desktop.

Each mouse + keyboard

combination includes a popup IIEI le right: (Doubtectick J[ 1]
menu offering the following Hold left: [_Contewt J[ ]
entries: Hold rignt: [_AppSwitch J[ ]
Ctri+left: | Contenxt I :

Nothing Ctri+Alt+tert: [ Object |
No special actionis Ctr l+Alt+right: | Content | :

assigned to this.
Doubleclick
The mouse click is interpreted as a double left-click.

Context

—

Calls up the context menu.
icons

A popup isdisplayed with entries for each icon installed on the desktop.
Drives

A popup isdisplayed listing all available drives and partitions.
AppSwitch

A popup is displayed listing all running applications, allowing you to
switch to a different running program.

CPXs
A popup isdisplayed showing all active control panel CPXs.
FolderPop

The contents of a given folder will be displayed as a popup. The desired
folder has to be specified via the file selector that appears when the empty
box to the right of this popup is clicked on. To remove an entry without
choosing another, enter a space in the filename field.
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Object

Select this entry to assign the mouse + keyboard combination to open an
object. To assign the object click on the empty box to the right of the
popup menu and select the desired object using the file selector. To
remove an assigned entry altogether, enter a space in the filename field.

Hold delay

With this editable field you can set the time after which a button held
down without moving the mouse is interpreted as a “Hold”. If the mouse is
moved during this time interval then the action will be interpreted as
“dragging”. If the mouse button is released within the set time then it will
be treated as a normal click.

4.20 Settings... > Notepad

Position note on creation Position note on creation
_[_]_I"ﬂg note in real-time
Active (crossed): On creation, desktop Send attribute tags to editor
12 s Attribute tags on DragGDrop
notes are positioned under the mouse Merge notes with Shift

cursor ready to place on the desktop. 5 Notepad | tank
Notlepa icCon on ces op

Inactive: On creation notes are

positioned centrally on screen. OLGA-ewtender : N
BAK

BAK-entender:
Drag note In real-time . -

Active (crossed): On dragging a desktop note with the mouse the contents
remain visible and move with the cursor in real-time.

Inactive: On dragging notes with the mouse a ghost outline representing
the note frame is displayed. This option is useful on slower systems if
real-timedragging is too jerky.

Send attribute tags to editor

Active (crossed): The note attribute tags are displayed when the note is
edited using a text editor, where they can be edited directly.

Inactive: Just the plain text of the note note without the attribute tags is
sent to the text editor.

Attribute tags on Drag&Drop
Active (crossed): The note attribute tags are passed to the target
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application during Drag&Drop operations.

Inactive: Only the plain note text but not the attribute tags are passed to
the target application.

Holding down the [Shift] key temporarily reverses the current setting.

Merge notes with ‘Shift’

Active (crossed): Dragging notes onto each other with the [Shift] key held
down merges the contents. Without the [Shift] key one note will simply
cover the other, but they remain separate.

Inactive: The contents of notes are merged whether the [Shift] key is held
down or not.

Notepad icon on desktop

Active (crossed): A notepad icon is installed on the desktop which
provides a convenient way to create new notes.

Inactive: New notes can be created via the Speclal > Notepad... menu option.

OLGA-extender

ITf OL.GA is installed under a multitasking OS, enter in this editable field
the extender that is to be appended to the filename by the editor called by

the Editor button in the Notepad dialog (see 2.4 Notepad functions). Only
extenders listed in the OLGA.INF file can be recognised.

BAK-extender

A file extender entered in this editable field is used by the internal jinnee
note editor to save backup files. On note deletion the corresponding
backup files are also deleted.

4.21 Settings... > Parameter passing

“. 7 folder passed

Active (crossed): The parent directory ]

“ ” . '..' folder pﬂSSEd
pseudo” folder entry is passed together 'Pooped’ folder passed

with other parameters. Not all =~OPF P

programs can cope with this parameter.

AU-protocol timeout: 383' sec

Inactive: The parent directory “pseudo” |
folder entry is not passedas a parameter. OragiDrop timeout: 30800 ns
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‘Popped’ folder passed

Active: (crossed): If the parent directory of a selected object is popped
open and selected, thisis also passed as a parameter.

Inactive: The parent directory is not passed as a parameter.

AV-protocol timeout

The timeout in seconds before a “forgotten” AV-protocol buffer is
automatically released can be entered in the editable field.

Drag&Drop timeout

The timeout in milliseconds before a Drag&Drop attempt is aborted in
the case the receiver has not replied can be entered in the editable field.

4.22 Settlngs... > Paths | Shutdown: c:\amsvnsmnssnsuuwm.pn&____—l
. ‘ ' ] Paraltel start

Thisdialog contains all the most Kobold: E:\DISK\KOBOLO\KOBOLD .PR6L . __

important jinnee related paths. vestebin: | __ -

Shutdown E :::-!%::I'::'l::f?.' nenu item

Exceplions: A._.

Enter your preferred program to be
run when shutting down the
computer into the editable field. This
can be done by double-clicking on
the field and using the file selector or by typing in the complete path.
This is automatically preset to work with a standard MagiC setup:

CNGEMSYS\GEMDESK\SHUTDOWN.PRG

If the $SDMASTER environmental variable is set and you would prefer
jinnee to use this, leave the Shutdown editable field empty.

lcons: ICONS . INF -
CPH poth: CINCPHN e

Parallel start

Active (crossed): The shutdown program is started in parallel, i.e. jinnee
does not quit beforehand. This option should not be used under MagiC
with the supplied SHUTDOWN.PRG.

Inactive: The shutdown utility is not started in parallel. Select this
setting for running the SHUTDOWN.PRG supplied with MagiC.
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Kobold

Enter the path to Kobold into the editable field using the file selector or
manual entry.

Wastebin

If you want to install a recoverable wastebin which stores deleted files in
a holding folder before final deletion, enter the path to the folder into the
editable field using the file selector or manual entry.

After this objects dragged to the recoverable wastebin are moved to the
holding folder and can be permanently deleted using the Speclal > Empty
wastebln menu entry.

Show real wastebin

Active (crossed): The real, non-recoverable wastebin icon is also displayed
on the desktop, and this can be used for deleting files immediately; once
objects are dropped on this icon they cannot be recovered.

Inactive: Only the recoverable wastebin icon is displayed.

Use with ‘Delete’ menu item

Active (crossed): Files deleted using the Object > Delete... menu entry or the
[Control] + [Delete] keyboard shortcut are moved to the recoverable
wastebin.

Inactive: Files deleted using the Object > Delete... menu entry or the [Control}
+ [Delete] keyboard shortcut are deleted permanently.

Exceptions

Drive letters entered into the editable field will not move files to the
recoverable wastebin. Files on these devices are deleted immediately. This
is useful for slow devices such as floppy disks.

icons

Enter the name of the file containing the assignment of jinnee’s icons,
normally ICONS.INF, into the editable field, using the file selector or

manual entry. The icons can be configured via the Speclal > Icon manager...
menu entry.

CPX path

So that jinnee can offer the installed control panel items in, say, context
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menus on the desktop, the correct path to the CPXs has to be entered into the

editable field, using the file selector or manual entry. Normally this will
be CACPX\.

4.23 Settings... > Popups

Max inum q__ entries (@=untimited)
Thisdialog contains options for Delayed opening: AB________________________

configuring jinnee’sdirectory Delay: 750 s
window and desktop popups.

[ | make selection with mouse click

Maximum x entries

This editable field sets the largest number of visible entries, i.e. the
maximum height of the popups (including any scrolling marks). If there
are more entries in a popup than are visible, you can scroll with the up-
and down-facing triangles. If you enter “0” then the popups may take up
the whole height of the screen.

Delayed opening

In this editable field you should enter drive letters for all interchangeable
media drives where it may take some time to check whether a medium has
been inserted or not floppies in particular.

Delay: x ms

jinnee opens the sub-popups for the drives entered above only after the

time in millisesonds entered in the editable field has elapsed. This
prevents irritating drive access attempts to possibly unloaded drives if
you “accidentally” brush the relevant entries with the mouse cursor.

Make selection with mouse click

Active (crossed): Selections from the popups are always made with a
mouse click, even if the popup was called by holding down a mouse
button. In that case you have to first release the mouse button and then
make a selection with a new click on the popup entry.

Inactive: Releasing the mouse button with the cursor on a highlighted
popup entry selects it immediately.

93



jinnee configuration

4.24 Settings... > Program start

Save desktop on removing from
Sove desktop on removing from memory
memory Save desktop on shutdown/program end
] Save resolution dependent
Active (CI‘OSSEd): jinnee saves | Update window after progrem termination

the current desktop setupina Autostart detey: 8 _ ms
~ Defaull mode

temporary fileif jinnee is L _
unloaded from memory when Muttipte start [ Ask ___ }
launching a program, and will Ao 'é' k092
use these when jinnee is O Single (remove jinnee from memory)
reloaded afterwards. The Singletasking:

. : @ Parallel (jinnee stays resident)
settingsin JINNEE.INF are O single (remove jinnee from memory)

not overwritten. |

Inactive: The desktop is not saved. On reloading jinnee the settings in
JINNEE.INF are used.

Save desktop on shutdown/program end

Active (crossed): On exiting jinnee or shutting down the computer the
current desktop is saved in a temporary INF file which is loaded the next

time jinnee is launched.

Inactive: No temporary INF file is saved, jinnee loads JINNEE.INF on
starting.

Save resolution dependent

Active (crossed): A resolution dependent temporary INF is saved with the
bit-depth as part of the filename.

Jinnee offers a choice between no window updates, global window updates
or application dependent window updates.

Update window after program termination
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Active (crossed): After any program ends jinnee updates all directories.

But you may prefer to leave this off, as activating New window for individual
programs in the Special > Applications... dialog makes them update just their
own directories when they terminate. For example, by their nature,
archive handling programs usually create extra files and it’s usually
exactly these files you're interested in.
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Inactive: jinnee does not automatically update directories but you can
still manually update windows using the [Esc] key.

Autostart delay

The time delay, in milliseconds, between individual auto-start programs
can be entered in the editable field. This can be useful if you're using any
programs which take longer than normal to initialise and release
memory.

The Default mode part of the dialog sets the default modes for launching
programs under multitasking operating systems.

Multiple start

The multiple start popup configures how jinnee responds if you launch a
program which is already running. The following options are available:

Never
Programs are only ever started once.

Ask

A dialog box is displayed asking whether a second copy of the program
should be launched.

Pass parameters

Instead of launching a second copy, file parameters are passed to the
running program which would normally load the file/s.

Start

Multiple copies of a program will be launched without asking.

The default jinnee behaviour under both Multitasking and Singletasking
operating systems can be specified as either Parallel or Single.

Parallel

jinnee remains memory resident as other programs are launched.

Single

jinnee is unloaded from memory before another program is launched,
which is mainly useful if you need the extra memory occupied by
jinnee.
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4.25 Settings... > Programs I GER progrenms: |m.Pm:i,t.HPP,!.PHH,#?HPI{_______‘
GEM with params: [#.GTP_______ - ]

o o 108 progrens : [+.70s I ]
This dialog contains five T0S with params: |[s. e - ]
edltable flE].dS WhICh include l Accessories: l# : Hl’,‘[-:-:: MACH ‘

the default file extenders for
the different executable

Executable bit: o ———

Mac progroms on: e e e e e e e o e e e e e e e e e
program types: I — —

GEM programs: *PRG, * APP,*PRX *APX
GEM with params: *GTP

TOS programs: *TOS

TOS with params: *TTP

Accessorles: * ACC, *ACX

These entries can be edited manually or via the file selector (at your own
risk)!

Executable bit:

In this editable field you can enter drives for which the executable bit is to
be evaluated. With this bit set for a file on the corresponding drive, the file
will be recognised as an executable program, irrespective of the filename
extender.

The executable bit is a part of the access rights, and can be set or cleared
via the context menu or the “File information” dialog. The file system in

use must support this feature explicitly.

This option is present as some file systems apprently have the executable
bit set for all files (and have no means for clearing it).

Mac programs on:
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Here you can enter drives from which you may wish to start Mac
programs. Naturally this is only possible under MagiC Mac and has no
effect on other systems. Reading the directories of the drives entered here
i1s necessarily somewhat slower, hence you should only enter drives here
from which you really really want to start Mac programs.
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4.26 Settings... > Quick-keys

Here you can define up to five

sets of ten program entries _set 1 |  aurex mems
each thatareto appear under ‘ | :\PPP1_B\ICONNECT.PRG_____
the Quick menu entry and/or be [ F2  ]|1:\EMAILER.23F\EMAILER.APP______ -]
launched with keyboard [ F5 ]|1:\CAB2_8\CRB.APP__________________
shortcuts. The popup menu at [1:\CIHCONM\C | HCOMM . PR6_—___________
the top selects between the [ F5 ] [1:\CONN_95\CONNECT.PRG| ____________

five available sets.

The programs are specified in
the large editable fields in the %
middle of the dialog, either |

manually or by l —
double-clicking on the field
and using the file selector.

LOOXKX KX KX

| |

Clicking on the buttons down the left hand side lets you set the individual
keyboard shortcut combinations for launching each program. A sub-dialog
appears inviting you to press the desired key or key combination. If desired,
you can assign both Shift keys independently by activating the Differentiate
‘Shift’ keys checkbox in the sub-dialog. In that case the shortcut will be shown
in the button as a left- or right- instead of upward-facing arrow. A shortcut
can be deleted by selecting it and clicking the mouse.

In Quick menu

A column of option boxes down the right hand side set whether the
program is displayed in the Quick menu or not.

Active (crossed): An entry for the specified application appears in the
Quick menu.

Inactive: No entry for the specified application is displayed in the Quick
menu.

Important!

Quick-keys can be globally de/activated via the Special > Quick-keys menu
entry.
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4.27 Settlngs... > Show Auto text mode from B__ objects (®=never) —l
Eg Once tenl - always tent
Show '..' folder
Extenders right-justified [X D0OS only
Auto text mode from x objects

Mininum icon display: | 2/3 visible |
Rininun tent display: | Name visible I

If adirectory contains at
least the number of objects
specified in the editable

, - _ ~ Text disploy spoacing
fleld: jinnee aUtomatlcally Space from window border: 12 pinel
displays the directory in ' Space after filenames: 16 pinel
text mode. L Space between components: 10 pixel
- x=1:Directory windows

are always displayed as text.
- Xx=0:Thesetting in Show > As Icons applies.

This setting is evaluated every time a directory is changed or re-read.
Individual windows can be toggled between icon and text display using
the window info-line icons or by toggling Show > As Icons in the menu.

Once text - always text

Active (crossed): If the Auto text mode from x objects option is active jinnee
will not automatically switch back to icon display even if the number of
objects falls below the preset threshold.

Inactive: This option isignored.

Show “..” folder

Active (crossed): Every subdirectory (but not the root directory) contains
an extra folder icon representing the parent directory named “”
Clicking on thisicon steps up the directory tree and has the same effect as
clicking the Closer icon but offers the advantage that object/s can be
moved or copied one level up the tree by dragging files to this object; the
same applies using the spring-folder method via Drag&Drop.

Inactive: No parent directory icons are displayed.

Extensions right-justified

Active (crossed): In text mode, all file extenders the part of the filename
from the dot (point/full stop) onwards are displayed right-justified.

DOS only
When this is inactive (uncrossed), this setting affects all drives, whether
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they support long filenames or not; when it is active, only the drives
gsupporting purely DOS-style 8+3 filenames have the extensions
rightjustified.

Inactive: The extenders are always closed up against the filename.

Minimum icon display

From the popup, select how much of an icon that may be obscured by the
window border should remain visible before it is wrapped to the previous

column.

The following choices are available:
- Fully visible

- 1/2 visible

- 2/3 visible

- 3/ visible

- 4/5visible

Minimum text display

From the popup, select how much of the file or folder names that may be
obscured by the window border should remain visible before the line is
wrapped to the previous column. The following choices are available:

- Fully visible

- Name visible

- 1/2 visible

- 2/3 visible

- 3/4 visible

-~ 4/5visible
Text display spacing

The following settings set the distance, in pixels, between the individual
window objects and the window border. The smaller the spacing the more
difficult it becomes to select objects especially using the rubber band
selection method. The following choices are available:

- Space from window border
- Space after filenames
- Space between components
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4.28 Settings... > Window r Set pallette when topped
Include AV client windows when cycling
Set palette when topped Only remember the first position of a window
Save open windows In the INF file
Active (crossed): When a Save standard positions in the INF file
s . . . Open folders in a new window
jinnee directory window is | Change directories with Alt+letter
topped the jinnee colour

Hor izontal slider
Uindow closer closes immediately

paIEtte’ as defined by Hotclose timer: sul ns
JINNEE.PAL, isinstalled. If L

_ _ [ Scroll with right mouse button, factor: 1
JINNEE.PAL is not available N

_ [ ] Truncete window title, button width: 13 spaces
the paletteinstalled on
starting jinnee is used.

Inactive: The colour palette is not changed when a window is topped.
Include AV client windows when cycling

Active (crossed): When cycling through windows using the Window > Cycle

windows menu option the windows of AV client applications that support
global window cycling are taken into account.

Inactive: Only jinnee windows are cycled.
Only remember the first position of a window

Active (crossed): The position at which a window is opened for the first
time is stored. If it is subsequently re-sized and then closed and
re-opened, it will be opened at its original position.

Inactive: jinnee maintains standard positions for windows established
through the window number . Window 1 has a certain position, window 2
a different position and so on.. As windows are closed their positions are
automatically taken over. To adopt new window positions:

- Deactivate the Only remember the first position of a window option.
- Place windows in the desired positions.

- Closeall the windows

- Activate the Only remember the first position of a window option.

This function has no effect if Intelligent location is active in Speclal >

Settings... > Window placement because jinnee searches for a suitable place
to display each window on-the-fly.

Save open windows In the INF flle
Active (crossed). On starting jinnee windows will be opened at the exact
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positions they were displayed at the time the INF file was saved.

Inactive: Window positions are not saved in the INF file, so no directory
windows will be open when jinnee is started.

Save standard positions in the INF file
Active (crossed): The standard window positions are saved in the INF file.
Inactive: The standard window positions are not saved in the INF file.
Open folders in a new window

Active (crossed): On opening a folder a new directory window is always
opened while the old one remains on screen (standard Mac behaviour).

Inactive: On opening a folder the same window will be used,
automatically replacing its parent directory.

Holding down the [Alternate] key temporarily forces the opposite
behaviour, so when the checkbox is active the directory will open in the
same window and when it is off a new window will open with the
directory.

This function also works when closing folders for moving back up the
directory tree to the parent directory.

Change directories with Alt+letter

Active (crossed): [Alternate] + [Letter] displays the corresponding drive
directory in the currently topped drive window.

Inactive: [Alternate] + [Letter] opens a corresponding drive directory in a new
window. Holding down the [Shift] key as well temporarily forces the
opposite behaviour.

Horlzontal slider

Active (crossed): Newly opened windows will have a horizontal slider at
the bottom with which their contents may be scrolled sideways.

Inactive: Newly opened windows will not have a horizontal slider. This is
sensible, particularly with smaller screens, as jinnee always optimises the
width of directory windows and by omitting the bottom slider wins a
little more space for the window contents.

Window closer closes immediately

Active (crossed): Clicking on the Closer icon closes the window
immediately.
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Inactive: Clicking on the Closer icon displays the parent directory.

The optional alternative Closer icon in the window info-line will adopt
the opposite behaviour to this setting, changing to a leftfacing arrow.
When this checkbox is switched off, the info-dine icon looks like a
slightly enlarged Closer and while the window’s Closer now moves up the
tree, its appearance does not change.

The parent directory can also be displayed by clicking on the optional..icon

or by using the [Undo], [Control] + [Backspace] or [Control] + [H] key
combinations.

Hotclose timer: x ms

A left-click and hold action (instead of the usual click and release) over
the Closer icon causes jinnee to automatically step up the directory tree
level by level at the time interval entered into the editable field (0 to 999
milliseconds). The path displayed in the window title line at the moment
the mouse button is released will open the corresponding directory
window.

Scroll with right mouse button, factor: x

Active: A right mouse click and hold initially outside a directory window,
with the cursor then moved into the window (while the button remains
down) displays the hand icon, which can be used to drag the directory
window contents in real-time to look at the whole directory without
using the scroll bars. The speed of movement can be controlled by
entering a factor (1 to 9) for the distance the contents move for a given
mouse movement the higher the factor the faster the scrolling.

Inactive: Normal right mouse click behaviour. You can still scroll through
the whole directory with the window’s scroll bars.

Truncate window title, button width: x spaces

Active (crossed): Paths which are too long to fit in the window path line
are shortened in the middle, using “” characters to indicate where the
path has been abbreviated. The Button width editable field sets the width (in
characters) of the window path line which is to be omitted. This may need
altering if the screen resolution is changed.

Inactive: Paths which are too long to fit in the window path line are cut
off at their end.
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4.29 Settings... > Window placement

- [X] Automaticalty size

Centred
Automatlcally size E Hor Izontal oniy
icon proportions: Uidth: 4L_ Height: 3__
fexnt proportions: Width: 4__ Height: 3__ ||

Active (crossed): Windows are
automatically sized, taking only
enough space to display the files | & Intettigent tocation -

: . In top leftl corner of the free ares
as necessary, but with sufficient E only If the normal place Is eccupled
files always visible. Take mawinum S__ windows into account (8=all)
Inactive: Windows are opened at |- nistance from screen edge
their previous position and size, Left: 8__ Upper: 8__ Right: 8__ Lower: 16_
depending on other settings. X Use $SCREENBORDER |
Centred

Active (crossed): jinnee calculates the new window position from the
centre of the window.

Inactive: jinnee calculates the new window position from the top left
corner.

Horlzontal only

Active (crossed): jinnee only adjusts the width of windows, leaving the
window height unchanged.

Inactive: jinnee adjusts both the width and height of windows.
icon proportions

The Width and Helght settings determine the width/height ratio of opened
icon windows.

Text proportions

The Width and Height settings determine the width/height ratio of opened
text windows.

Intelligent location

Active (crossed): jinnee attempts, wherever possible, to open new windows
so they do not overlap an existing open window.

Inactive: Windows are opened at their previous size and position.

This behaviour may be modified still further:
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In top left corner of the free area

Active (crossed): jinnee opens new windows at the top left corner of any
free area available.

Inactive: jinnee opens new windows in the centre of any free area
available.

Only If the normal place Is occupled

Active (crossed): If the normal window position is occupied jinnee
intelligently re-positions the window in free space.

Inactive: Windows are opened at their normal position.

Take maximum x windows Into account (0=all)

This editable field sets how many windows are taken into account when
calculating window positions. For example, a setting of 5 takes into
account the positions of the first five windows but ignores any other open
windows. Enter 0 to take all windows into account.

Distance from screen edge

Here the distance from the Left, Upper, Right and Lower edge of the screen, in
pixels, in which windows will not be placed can be freely defined. This
makes it easy to ensure windows are not opened over your desktop icons
or open over an installed start- or application-bar and so on.

When Use $SCREENBORDER is active, instead of the values in the editable fields
the area left clear will depend on the value stored in the environmetal

variable of the same name (its format is similar to the above pixel values for
lefttop,rightbottom).

The environment variable can be set in various ways. In MAGX.INF use an
entry such as:

# ENV SCREENBORDER=0,40,0,30

which gives no spacing at left and right, 40 pixels at the top and 30 at the
bottom.
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o Jinnee’s context menus

Jinnee now offers context menus, which can be assigned to one or more
mouse-click options in the Special > Settings... > Mouse clicks dialog. A context
menu always contains entries offering available and relevant actions “in the
current context” (at the mouse position). Furthermore, jinnee’s context

menus can have additional functions added at any time with so-called
“plugins”.

Often the context menu offers the quickest and simplest way to perform a
given action.

All context menu entries made available by jinnee are listed below together
with brief explanations. The character “=>” denotes that the corresponding
entry opens a further sub-popup.

Open

Opens the selected object(s).
Edit note

This appears only for notepads and permits their contents to be modified.
Show

Opens the selected objects with the installed display program (“Viewer”).
Edit

Opens the selected objects with the installed editor.
Show original

For links and desktop objects this displays the original object directory:.
New object

Creates a new folder or new (empty) file in folders or windows.
Information

Shows the relevant information for the selected (highlighted) objects or
the directory window clicked on.

Contents =>

With folders or directory windows this opens further sub-popups with
which you can “move down” the directory tree and select objects from
lower level folders without having to open a directory window for them.
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Step up =>
With this entry you can move up to the next higher level in the folder
hierarchy. Holding down the [Alternate] key opens a new window for this.

icons =>

This only appears on the desktop and opens a sub-popup with selectable
entries representing all icons present on the desktop.

Drives =>»

This only appears on the desktop and opens a sub-popup with selectable
entries representing all available drives.

Applications =>

This also only appears on the desktop and opens a sub-popup showing all
currently running applications.

Accessorles =>

Opens a sub-popup offering all installed accessories for selection.
MenuBarprg or A-MAN.PRG has to be installed on the system to make
this work.

CPXs =>

Opens a sub-popup that permits calling any of the installed control panel
items. If you select the CPXs entry itself then the CPX folder will be
opened on screen.

Copy

This acts the same way as the Copy menu entry on selected (highlighted)

objects. In addition you can copy the contents of desktop notes to the
clipboard.

Merge

Similar to Copy but the data is appended to the existing clipboard contents
rather than overwriting SCRAPTXT.

To the wastebin

Moves the selected (highlighted) object(s) or dekstop note to the
recoverable wastebin folder.

Delete
Deletes the selected (highlighted) object(s) or desktop note.
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Delete icon
Removes the selected icon from the desktop (no files will be deleted).
Insert

In folder and directory windows this entry works in the same way as the

Insert menu entry. Invoked from the desktop a new desktop note will be
created into which the clipboard contents will be inserted. Invoked from
a note the clipboard contents will be appended to the existing note text.

Move

Moves previously highlighted objects to the position clicked on (in folder
or directory windows).

Create link

Creates links at the position clicked on to all previously highlighted
objects.

New note

Opens the Notepad dialog to create a new note on the desktop.
Select all

Selects all objects in the window or on the desktop.

Empty
Clears the recoverable wastebin folder or the clipboard.

Eject
Ejects the medium from the highlighted drive(s), if this is possible.

Attributes =>

This permits the file attributes of all highlighted files to be altered. The
current status is indicated with a tick. If some of the files in a selected
group or folder have different attributes, then the corresponding entries
will be enclosed in square brackets; the tick will be set if the majority of
objects have this option set.

Access rights
Permits alteration of the access rights for all selected files.

Program flags =>
Permits alteration of the program flags for executable programs.
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Activate

Activates files that have been deactivated by suitably renaming their
extender. Can be applied to files with PRX, APX, GTX, ACX, TOX, TTX or
CPZ extenders.

Deactlvate

Deactivates files by renaming their extender. Can be applied to files with
PRG, APP,GTP, ACC, TOS, TTP or CPX extenders.

Uppercase

Converts the name of all selected (highlighted) objects to capitals.
Lowercase

Converts the name of all selected (highlighted) objects to lower case.
Capltalise

“Capitalises” the name of all selected (highlighted) objects, i.e. the first
letter will be in capitals, the rest in lower case.

Show =>

Permits changing what is shown in directory windows, as well as the
order the objects are sorted in.

New notepad

Creates a new notepad icon on the desktop at the position clicked on.
New wastebin

Creates a new wastebin icon on the desktop at the position clicked on.

Switch to Mac OS

Under MagiC Mac this switches over to the Mac-OS side.
Shutdown

Executes the shutdown procedure.
Plugins =>

This opens a sub-popup offering all installed plugins suitable for
currently highlighted objects for selection. The context menu can be
extended with such plugins by any desired amount. The plugins must be
placed in the folder JPLUGINS\CONTEXT\ in the jinnee directory (or
$HOME).
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6 Context menu plugins

This section is primarily of interest to programmers. It explains how you
can extend jinnee with your own context menu plugins.

jinnee looks for the plugins in the folder JPLUGINS\CONTEXT\. Both of
these folders are normally in the same directory as jinnee, but can also be
created in, say, SHOME.

You can add new plugins to the CONTEXT folder at any time. It is not
necesary to quit and re-start jinnee they will be available immediately.

Plugins can be used currently only with “directory objects” , i.e. files, folders
and drives. They cannot be used with desktop notes, for instance.

Plugins can be any type of file. If they are programs, they will simply be
launched, if they are normal files they will be “opened” in other words
passed to the program installed for them. This permits scripts, for instance,
to be used as plugins.

When a plug-in is selected, all highlighted objects are passed to it via the
command line.

There are measures to ensure that a plug-in only offers selections for suitable
objects:

jinnee looks in the plug-in file for the magic value “JCtxtPlgl”. If it is not
found then the plug-in will simply appear always. If it is found, then the
magic value is followed by a list of key/value pairs. As it is pure ASCII data
the whole thing can be used in scripts too (comments are always possible).
The individual key/value pairs are separated by the pipe character “/”. If the
key takes a value then the value is separated from the key by the equality

character=*
Important:

It isimperative that “End” is entered as the last key to terminate the list.
The following keys are available at present (they are not case sensitive):

Group

Sets the group-ID of the plug-in. All plugins of the same group are
collected together and displayed separated from other groups.
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Nameg

Sets the name of the plug-in as it is to appear in the popup. Default is the
filename.

Flle
O or 1. Determines whether the plug-in can be used for files. Default: 1
Folder
Ditto for folders. Default: 1
Fllelink
Ditto for file links. Default: 1
Folderlink
Ditto for folder links. Default:1
Drive
Ditto for drives. Default: 1
Directory
Ditto for directory windows. Default: 1
Desktop
Ditto for the desktop. Default: 1
Deskicon
Ditto for desktop icons. Default: 1
Program
Files have to be executable programs. Default: 0
Scrap
Has to be applied to the clipboard folder. Default: 0
Trash
Has to be applied to the recoverable wastebin folder. Default: 0
One
Has to be applied when only one object is selected (highlighted). Default: 0
Match

Here you can specify a mask to restrict the files that the plug-in may act
on.

End
Terminates the list.
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7 Miscellaneous features

7.1 Keyboard layout and shortcuts

[Control] during Copy operations moves files instead of copying them.

[Alternate] + [Drive letter] opens the directory window to the
corresponding drive partition in a new window.

[Shift] + [Alternate] + [Drive letter] opens the directory window for the
corresponding drive partition in the currently topped directory
window.

[Alternate] during Copy operations enables object/s to be renamed
on-the-fly, unless [Alternate] has been configured to create links.

[Shift] + [Alternate] or [Shift] + [Control] during cursor drag operations
creates a symbolic link.

[Alternate] + double-click on desktop file icons opens a window to the
path where the original file is located.

[Alternate] + double-click on a symbolic link follows the link.
[Alternate] on opening a file sends it to the file viewer instead.
[Control] on opening a file sends it to the editor.

[Control] + [Alternate] + double-click on a file opens the directory to the
application installed for that filetype.

[Shift]-clicking to start a program switches between single and parallel
mode.

[Undo], [Control] + [H] or [Control] + [Backspace] displays the parent directory
or closes the directory window.

[Esc] re-reads the directory displayed in the top window.

[Esc] during drag operations aborts the operation. This is valid for all
drag operations. For example, dragging icons or desktop notes.
Two-button mouse users can alternatively press both mouse buttons to
abort drag operations.

[Tab] during drag operations fixes a directory window opened during
spring-folder navigation so it doesn’t close again. This can be applied
repeatedly to fix any desired windowys.
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- [Cursor] keys scroll. If the Cursor keys move selection option in Special >
Settings... > Autolocator is active the [Control] key must be held down to
achieve the same result.

- [Shift] + [cursor] keys moves through directories a window-full at a time.

~ [Cursor right/left] keys open/close folders in Single column text display mode
only.

- [CirHome] skips display to the directory origin.

- [Shift] + [CirHome] skips display to the directory end.

- [Control] + Closer icon closes the window.

- [Alternate] + Closer icon display parent directory in new window.

- [Alternate] + double-click on a folder/s opens new windows to display the
content/s.

- [Control] + double-click on a folder opens a popup showing the contents
of this folder.

- [Control] + [Delete] deletes the selected objects.

- [Shift] during drag operations can be used to drag along objects selected
In other windows. This makes it possible to drag all selected objects
from all windows to a program, which receives all the filenames as
parameters.

- [Space] or [Esc]: Clear Autolocator entry or selection refer to 4.1 Specilal >
Settings... > Autolocator for more details.

7.2 Jinnee and KOBOLD

Jinnee can automatically hand over Copy, Move and Delete file operations to
KOBOLD. To do this KOBOLD must be correctly installed and confi gured in

the Speclal > Settings... > Paths dialog.

KOBOLD can also be used as a desktop accessory but the path must still be
entered in the Paths dialog.

7.3 Jinnee and MagIC

For optimal co-operation when running jinnee under MagiC please observe
the following points (normally these are handled automatically during
installation):
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- In the MagiC configuration file MAGX.INF jinnee should be installed
as the Desktop (Shell). For example, assuming jinnee is installed on
drive Cin a folder called JINNEE:

# SHL CNA\JINNEE\JINNEE.APP

Only when jinnee is installed like this can programs be started in Single
mode.

- It's also just as important to install jinnee as the AV-Server. Directly
under the # SHL line entry add the following line using an ASCII text
editor:

# ENV AVSERVER=JINNEE

- If you have disabled the Parallel option for any installed applications in
the Speclal > Applications... dialog you should activate the Save desktop on
removing from memory option in the Speclal > Settings... > Program start dialog
if you wish to retain the same desktop layout when jinnee is re-loaded.
Unless this option is active the desktop is re-loaded with its default
settings.

- To launch an application in Single mode from a directory window hold
down the [Shiftf] key. This works without having to install the
application beforehand.

7.4 jinnee without MagiC

You must install the enclosed WDIALOG utility in your AUTO folder. For
more details refer to the documentation accompanying WDIALOG.

7.5 |innee and scrolling mice under MagIiC Mac

Under MagiC Mac, jinnee from version 2.5 onwards supports mice with a
so-called scrolling wheel. You can buy many mice that have such a wheel,
particularly for newer Macs with a USB port. So that the scrolling wheel can
be used for MagiC programs as well, you have to proceed as follows:

The USB driver has to be set on the Mac side so that when using the scrolling
wheel with MagiC Mac active it simulates the key-presses [Apple] + [Cursor-up]
and [Apple] + [Cursor down] respectively. The whole arrangement has been
tested with the “USB Overdrive” control panel which is universally usable
with all possible USB mice and joysticks (http:/wwwusboverdrive.com/). In
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this, use the button New to create a new setup specially for MagiC Mac in the
left area of the “USB Overdrive” window; then select in this case for Wheel Up
the setting Keystroke Command up and for Wheel Down the setting Keystroke
Command down. It is impossible to tell or guarantee here how and if this is
also possible with other mouse drivers.

If everything has been set correctly, then all vertical sliders in all MagiC
windows can be serviced with the mouse’s scrolling-wheel.

jinnee then “filters” the keypresses [Apple] + [Cursor] and translates these into
corresponding window messages that are then sent to the relevant program.

8 Flle matching

File matching makes it easy to select groups of filenames. Placeholders or
so-called “wildcards” are used to select the desired files with the minimum
of effort.

A well known example from the DOS era is ** which selects all files on
standard TOS/DOS 8+3 file systems. Another example is *TXT which finds
all files with the TXT file extender.

Important!

Because jinnee also runs on non-TOS/DOS 8+3 file systems, Unix style file
matching is supported. Therefore “*” is used to select all files instead of “**”
which will only find files which explicitly include a . character in their
filename, so it would miss README, for instance.

These file matching principles apply equally to the Autolocator, file masks,
for installing files (Open in the Applications dialog), icon colour display, the
filter,and icon assignments used in jicons.

The following rules apply for evaluating the matching assignments:

? anysinglecharacter
* anycharacter string (or nothing)

l..] any single character from within the brackets. For example [ACD]
selects all files which start with A, C or D.

[l..]not any of the characters within the brackets.

! an exclamation mark at the start of a file match inverts its logic. For
example "TXT selects all files whose extender is not TXT
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Multiple file matches can be entered using the comma “” or pipe symbol “” as
separators (not space characters!) and these are effectively logical OR
operations. For example ““C*H” selects all files and folders with a “C” file
extender OR an “H” file extender.

Alternatively logical AND operations are possible using the ampersand &
character. For example: “*TXT&!NOTHIS1TXT” selects all TXT files apart
from NOTHIS1TXT.

You should note that slightly different rules apply to the Autolocator, which
is “front-loaded”, which means jinnee internally appends a “*” to the
individual matching masks separated by commas, pipes or ampersands. If
you really want to set the end of an individual match, then you have to use a
semicolon “” for OR and a plus “+” for AND operations. The last (or only)
matching mask has to be terminated with a semicolon “” in order to
suppress the front-loading.

As there is no bracketing and OR and AND are not evaluated completely
from left to right, the mixed use of OR and AND is pointless. Therefore the
only meaningful use of AND is in connection with the NOT operator “/” to
exclude files from a match, as shown in the above example.

9 jinnee icons

Here a few words about icon-integration in jinnee.

Jinnee can use icons in two separate ways:

1. Normal Ilcons:

These are described in an INF file, normally ICONS.INF, that includes a
reference to a folder which contains the RSC file holding the icon data,
normally an ICONS folder inside the JINNEE folder.

The INF file also stores the information that determines which objects
display which icons. The INF file to be used can be set in the Special >
Settings... > Paths dialog.

The INF file can be configured using the “jicons” utility program
accessed via the Special > Icon manager.. menu entry.

To add new icons simply copy the desired RSC file to the ICONS folder to
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which the active INF file refers and the icons will be available for
assignment immediately.

2. Thumbnail-icons:

If jinnee finds a file named JINTHUMB.RSC in a directory, the icons it
contains are used purely for the objects in that directory, and the icons
are only loaded into memory if a window to that path is open. For
example, this is useful for folders containing lots of images, where a small
preview of each image can be created.

Please note that these icons are not assigned via an INF file. The
assignment is therefore made directly via the icon banners in the RSC

file.
Minl-icons:

Jinnee supports normal and mini-icons. Mini-icons may be up to 16x16
pixels maximum and must be located in the final tree in the RSC file.

Under GEM the icon width must always be divisible by 16, so jinnee
assumes that the real width of the mini-icons is always the same as their
height otherwise the width would always have to be 16 pixels. Mini-icons
are also assumed to be square. If a mini-icon is drawn too wide this can
lead to redraw errors. For example, a 12 pixel high mini-icon can only
contain set (visible) pixelsin the first 12 columns.

10 Questions and Answers
How can I retain my INF file from EASE?

Unfortunately you cannot. You could take a snapshot image of your Ease
desktop, then load this into jinnee as a background image and use it as a
template over which you can arrange your jinnee icons in the original
Kase positions.

How do I install a program for a particular filetype?

Highlight the desired program then select Speclal > Applications... followed
by Yes when asked if the application should be installed. In the
application list you should now enter the file extender to open this
application, for example “*TXT”.
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How do I create a clipboard icon on the desktop?

Open a directory window to drive C: and drag the CLIPBRD folder onto
the desktop. Close all the directory windows then highlight the

CLIPBRD folder icon and select Object > Information... and assign the name
Clipboard to theicon.

How do I create a recoverable wastebin icon on the desktop?

Create a folder on any drive to store trashed files, TRASH for example.
Set this folder in Speclal > Settings... > Paths as the path to the wastebin. Now
select Speclal > lcon manager..., select a suitable icon and double-click on it to
display a dialog where you can enter the name of the folder, TRASH in
our example, and set Folder as the filetype. You can optionally specify that
the icon will appear only on the desktop in this form. Exit the dialog via

the OK button and from the desktop drag the TRASH folder from the
directory window onto the desktop.

How can I start a programusing the keyboard?

Highlight the desired program then select Speclal > Applications... followed
by Yes when asked if the application should be installed. Click on the Set
key button to the right of the Quickstart-key entry then press the desired key
combination.

Alternatively the program can be entered into the Speclal > Settings... >
Quick-keys dialog and the desired key combination typed in after selecting
the button to the left of the relevant program entry.

Automatic floppy disk formatting using Kobold

First program or record a suitable formatting job in Kobold. In Special >

Applications... install Kobold as the default formatter program. To do this
double-click on the formatter entry (set to MGFORMAT.PRG by default),
select Kobold using the file selector, then enter the format job into the
command line. Now selecting Object > Format... will start the Kobold job.

How do I start a program in Single-mode?

To start programs in Single-mode from directory windows hold down
the [Shift] key on launching. If a particular program should always be
started in Single-mode select (highlight) the program and in the Special >
Applications... dialog, disable the Parallel option.
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How do I set a memory limit?

To limit the amount of memory a program can reserve for its own use
select (highlight) the program and in the Object>Information... dialog enter

the maximum memory in the Limit editable field. The program will be
patched using the MagiC LIMITMEM.TTP utility.

Important!

Please note this procedure will not work with most programs that have
been packed by something like the popular PFXPAK packer; this creates
smaller executable programs to save storage space, which self-unpack on
execution. Most packed programs can be unpacked to their original state
with a suitable utility such as LHARC (LZHSHELL.APP) or the
PFX UNPACK function in 2-in-1 for PFXPAKed programs. The
Signum!2-freshup program files are one example of PFXPAKing.

11 History

Jinnee v2.5 dated 05.09.00

- Support for access rights and of executable bits with suitable file
systems.

- Some new or improved Packers plugins in the context menu.

- Simultaneous development in several languages (currently German,
English and French).

- New function Deselect folders.
- The Delete function can now handle write-protected files.

- Program-independent support for mice with scrolling-wheel under
MagiC Mac.

(See: “7.5 Jinnee and scrolling mice under MagIC Mac”)
- More flexiblesettings for the file length display.

- New GEMScript-commands to install, deinstall and interrogate
programs by remote control.

- Inthe Notepad dialog you can now use [Control] + [U] and [Control] + [W].

- Folders can now also be popped shut with [Cursor-left] when any object is
selected in the popped-open folder.
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Innumerable further small corrections, supplements and bug fixes...

Jinnee v2.01 dated 22.03.99

Smart update configurable.

Bugfixes for popup scrolling, smart update and when converting
command lines.

Jinnee v2.0 dated 15.03.99

Context menus with plugins offering many new options.

Flexible popups. Folders and drives on the desktop may be opened
directly as popups.

Various freely assignable mouse-click options, which can be different
for “holding” and “dragging”.

More desktop click popups.

Starting of Mac programs directly from jinnee.

Display of available space on drives under MagiC Mac and MagiC PC
improved.

“Real’ names can be shown for control panel items (*CPX).

The destination window for spring-folders can be held open.

The “real” (more risky) wastebin icon can be removed from the desktop.
You can place several wastebins and notepads on the desktop.

New Merge menu entry.
Horizontal sliders can be switched off.

When creating desktop notes via GEMScript you can pass their
position on the desktop.

Better looking and many new icons.

Icon RSC files can be edited directly from within jicons. For this the
editor installed in jinnee for *RSC files will be launched.

Clearer arrangement of the icons in jicons.

Various small bugfixes and improvements, such as of desktop notes,
construction of command lines, opening of windows via the
AV-protocol, colour icons on Falcons, work-around for the menu-line
bug etc.
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jinnee v1.11 dated 01.10.98

Calculation of folder size.

Bugfixes, improvements, many minor things, larger internal
rearrangements.

Jicons: If errors arise, a more detailed error description is written to an
ERR file.

Mani-Tuuls published.

linnee v1.1 dated 26.05.98

120

Icon-concept completely re-worked. The addition of new icons is now
considerably easier.

Jicons improved and the search function improved.

Considerably improved notepad: No more size limitations, OLGA,
Drag&Drop, notes in GEM windows and so on.

Support for NVDI 5:
* Transparent dragging from icons and notepad.

* Automatic adjustment of any background image to the current
colour depth and palette.

* Scaling of desktop background images to full screensize.
MagiC 6 proportional system font support.
Smart date/time display:.
Windows can be pinned .
Filter symbol.
Optional browser-conforming Backdrop button.
Automatic media-eject on shutdown possible.
Automatic renaming in the wastebin folder.
Definable executable programs.
Flipflop display on switching options via keyboard.
All-iconitfy.
Many other minor changes...
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jinnee v1.02 dated 13.12.97

Correct display of 256-colour icons in Hi/TrueColor resolutions from
MagiC 5.20.

Abbreviated help text across the bottom of dialogs can be switched off.

Shortcuts can differentiate between right and left [Shift] keys.
GEMScript support implemented.

If the original file for a desktop icon has been moved this can now be
located using the file selector.

Falcon problems rectified.

The context application can now be called with a single right
mouse-click.

Optional automatic move instead of copy for operations within a drive
(like Mac-OS/Windows).

Optional Delete menu entry now selectable via the [Delete] key.

Mask dialog: A double-click on the popup menu displays the available
file extendersin the current directory.

Memory requirement to load 256-colour images in Hi/TrueColor
modes significantly reduced.

Number of entries in the Qulck menu raised from 15 to 20.
Various bugfixes and so on...

jinnee v1.01 dated 2.8.97

On systems which do not support colour icons the colour icons are no
longer loaded. A monochrome icon RSC file is included.

Various bugs rectified: double-slash error in the file selector, Pattern for
text display option, auto-start, copying in threads.

Pressing the [Tab] key can be used to fix windows opened during
spring-folder actions so they remain open.

SyssSound now functions on all Falcons.
No more redraw errors with overlapping desktop icons.

Jinnee v1.0 dated 22.7.97

First German release version.
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